Integrate etherpad into jitsi doesn't work like shown in the wiki

Hi,

I installed etherpad onto our VPS and made it working fine via http://domain:9001. Now I wanted to serve etherpad via Nginx as a subdirectory of the Jitsi domain and then link it into Jitsi. Found an example for it in the wiki: https://github.com/jitsi/jitsi-meet/wiki/Etherpad-addition-example.

But there were made some changes to the installations since then I think because on 443 there is listening a nginx instance which divides the traffic to turn and to the jitsi-meet ngninx. If I put the example into the port 80 part of my domain config from nginx everything is working like expected. If I put it in the ssl part (with port 4444) which is my aim it simply doesn’t work. I see only one “get” in the access.log and then it ends and the browser shows as new address https: //domain:4444/etherpad instead of https: //domain/etherpad and no site is loaded (timeout).

What do I have to do to reverse ssl proxy my etherpad session?

1 Like

Nobody with the same problem at the moment?

If you want the communication between the Jitsi Meet and the Etherpad server to be encrypted, use a reverse proxy.

If Etherpad will only be accessed via Jitsi and it’s installed on the same server, you don’t need that. Just set

etherpad_base: 'http://localhost:9100/etherpad/p/',

I installed Etherpad on a different server (with reverse proxy). My config values are here.

Another method could be to enable SSL within etherpad’s settings.json

This one is not working for me
My jitsi meet and etherpad is on the same server
etherpad is running on 9001
so i had confgure etherpad_base=‘http://localhost:9001/p/’ or ‘http://localhost:9001/etherpad/p/’,
it gives me localhost refused when i am clicking on open shared document

i am able to access with public ip with port (not within the jitsi)

Check if that helps…

So I had deployed my jitsi on domain, I had tried to access with “domain/etherpad/p/” on browser it is accessible

So I changed my etherpad_base url with

https://domain/etherpad/p/

Nginx configurations

location ^~ /etherpad/ {
proxy_pass http://localhost:9001/;
proxy_set_header X-Forwarded-For $remote_addr;
proxy_buffering off;
proxy_set_header Host $host;
}

(Don’t forget to complete the statement with “,”)
And it works for me

Thank you for the suggestion guys