Installing JITSI on CENTOS 7 - WHM OR CPANEL

Hello! Does anyone know how to install JITSI on a CENTOS 7 server?

I want to install it in a subdomain. Hopefully via Cpanel or WHM.

Thank you!

:grinning: :heart_eyes: :hugs:

Yes I have the same question. I would like very much to learn about this.

Actually I did it, and it wasn’t very hard using jitsi docker…

Install Docker:
yum install docker

Install Docker Compose

curl -L “https://github.com/docker/compose/releases/download/1.25.5/docker-compose-(uname -s)-(uname -m)” -o /usr/bin/docker-compose

Change to /opt folder (cd /opt)

Download jisti docker from github repository:

git clone https://github.com/jitsi/docker-jitsi-meet && cd docker-jitsi-meet

cd /opt/docker-jitsi-meet

Now copy env.sample to .env

cp env.sample .env

Set strong passwords in the security section options:
./gen-passwords.sh

Modify the .env file
nano ./.env

The env file is pretty descriptive on how to use you own subdomain.

Create the config directories
mkdir -p /opt/.jitsi-meet-cfg/{web/letsencrypt,transcripts,prosody,jicofo,jvb,jigasi,jibri}

After modifying the .env file and creating the config directories, you should now have a working jitsi environment:

from the /opt folder
To run in foreground mode (with logging) enter
docker-compose up

To run in background mode (no logging)
docker-compose up

To stop jitsi
docker-compose down

1 Like

hello, you say:

	from the /opt folder
	To run in foreground mode (with logging) enter
	docker-compose up

	To run in background mode (no logging)
	docker-compose up

sorry, I see the same command for the two options:

To run in foreground mode (with logging) enter
docker-compose up

To run in background mode (no logging)
docker-compose up

that is the same:

“”“docker-compose up”""

thanks by clear about if ALL is as user ROOT.

I apologize…

To run in background mode:

docker-compose up -d

Thanks, you can see I am very novice…

Please:
how I can uninstall ALL JITSI then I reinstall from ZERO but NO’T format VPS ?

By now,
each time when I need REINSTALL Jitsi for do TEST, I need FORMAT ALL VPS…

Some command to STOP, UNISTALL, then I can run ALL yours lines from FIRST to LAST, but without refresh VPS, OS, etc…

Regards :slight_smile:

	[root@cia docker-jitsi-meet]# docker-compose stop
	[root@cia docker-jitsi-meet]# docker-compose kill
	[root@cia docker-jitsi-meet]#

Hello
Unfortunately On centos 7 , at the end i got “permission denied” error when I enter “docker-compose up -d” or “docker-compose up” !
thank you

Hi Patrick,

I followed your instructions and was able to get jitsi installed, but have failed at the SSL cert part. Having a VPS with WHM/CPanel on Centos7, of course the certs are managed there. Ive really tried to find info for getting the certs working but have not had any luck.

Considering there is a browser restriction that webcam and mic can only work over https protocol, the last part of installing jitsi-meet has been unclear.

Have you gotten that far with your setup in specifying how docker sees the ssl certificates? Did you use lestencrypt and did it work alongside whm/cpanel?

Thank you kindly.

1 Like

Paul,

I have cpanel and I found the way to use it with SSL with cpanel.

You have to add a subdomain with normal cpanel with SSL certificate.

Then in the folder where the subdomain is located, add a file or modify the htcaccess file.

In the file put the following:

DirectoryIndex “”

RewriteEngine On
RewriteCond% {REQUEST_URI} ^. * / Index. *
RewriteRule ^ (. *) $ http://your public ip address: 8000 / [P, L]

RewriteRule ^ http://your public ip address: 8000 / [P, L] RewriteCond% {REQUEST_FILENAME}! -F RewriteCond% {REQUEST_FILENAME}! -D RewriteRule ^ (. *) http://your public ip address: 8000 / $ 1 [P, L]

and ready. :smiley:

i tried jisti installation with docker-compose as per above instruction…finally i got error in port 8443 - 400 Bad Request

The plain HTTP request was sent to HTTPS portnginx… at the same time port 8000 jitsi running but camera and audio not enabled…kindly help to sort out this issue…

Same here - the problem is that the url to download docker-compose is invalid - it will download a html file showing the 404 error from github. The “permission denied” is caused by missing x file attribute (but this won’t help, since you can’e execute the 404 page…). Try do install docker-compose using yum (can’t tell if it works, still having different issues…)

Hi,
I also needed Jitsi Meet on CentOS 7 but was disappointed that apparently no current RPM packages exist.
Then I started to create some packages and added them to a repo. Maybe it is useful for someone else:
http://www.tuxad.com/blog/archives/2021/01/24/jitsi_meet_rpm_packages_for_rhelcentosoel_7/index.html
Frank

1 Like

@Patrick_Glass I am trying to install on CentOS VPS everything runs fine except when I execute docker-compose up it gives me this error.
`Traceback (most recent call last):
File “urllib3/connectionpool.py”, line 677, in urlopen
File “urllib3/connectionpool.py”, line 392, in _make_request
File “http/client.py”, line 1277, in request
File “http/client.py”, line 1323, in _send_request
File “http/client.py”, line 1272, in endheaders
File “http/client.py”, line 1032, in _send_output
File “http/client.py”, line 972, in send
File “docker/transport/unixconn.py”, line 43, in connect
ConnectionRefusedError: [Errno 111] Connection refused

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “requests/adapters.py”, line 449, in send
File “urllib3/connectionpool.py”, line 727, in urlopen
File “urllib3/util/retry.py”, line 410, in increment
File “urllib3/packages/six.py”, line 734, in reraise
File “urllib3/connectionpool.py”, line 677, in urlopen
File “urllib3/connectionpool.py”, line 392, in _make_request
File “http/client.py”, line 1277, in request
File “http/client.py”, line 1323, in _send_request
File “http/client.py”, line 1272, in endheaders
File “http/client.py”, line 1032, in _send_output
File “http/client.py”, line 972, in send
File “docker/transport/unixconn.py”, line 43, in connect
urllib3.exceptions.ProtocolError: (‘Connection aborted.’, ConnectionRefusedError(111, ‘Connection refused’))

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “docker/api/client.py”, line 214, in _retrieve_server_version
File “docker/api/daemon.py”, line 181, in version
File “docker/utils/decorators.py”, line 46, in inner
File “docker/api/client.py”, line 237, in _get
File “requests/sessions.py”, line 543, in get
File “requests/sessions.py”, line 530, in request
File “requests/sessions.py”, line 643, in send
File “requests/adapters.py”, line 498, in send
requests.exceptions.ConnectionError: (‘Connection aborted.’, ConnectionRefusedError(111, ‘Connection refused’))

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “docker-compose”, line 3, in
File “compose/cli/main.py”, line 80, in main
File “compose/cli/main.py”, line 189, in perform_command
File “compose/cli/command.py”, line 70, in project_from_options
File “compose/cli/command.py”, line 153, in get_project
File “compose/cli/docker_client.py”, line 43, in get_client
File “compose/cli/docker_client.py”, line 170, in docker_client
File “docker/api/client.py”, line 197, in init
File “docker/api/client.py”, line 222, in _retrieve_server_version
docker.errors.DockerException: Error while fetching server API version: (‘Connection aborted.’, ConnectionRefusedError(111, ‘Connection refused’))
[20528] Failed to execute script docker-compose
`