Installing jitsi behind HAProxy with existing Apache setup

Hi everybody. Like many, I am trying to install this wonderful application to help co-workers, friends and family do video calls during times of quarantine. I have a VPS where I run Nextcloud and Apache, and HAProxy tells requests where to go. Jitsi installs fine, using Apache, but I am unable to create the SSL cert and I cannot seem to access the appropriate subdomain in a browser. What am I doing wrong? Any help is much appreciated.

When trying to install the SSL cert:

root@flobin:/home/robin# /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

   Domain: jitsi.domain.com
   Type:   unauthorized
   Detail: Invalid response from
   http://jitsi.domain.com/.well-known/acme-challenge/A0dDEPq-NwIYqeGUYW65rTmN4JsZK5vTZ5-rMR8yLws
   [136.XXX.XXX.168]: 404

This is my HAProxy config, Apache config and /etc/hosts.

Should the hosts have jitsi.domain.com in it?

Thank you for looking!

On my system the default site / config for Apache on port 80 was still enabled which blocked the VirtualHost jitsi configured on the same port.