Installing Jibri on AWS EC2

Hi,

I have been struggling to get ASLA loopback configured on a AWS EC2 instance running either Ubuntu or AmzLinux2. Followed multiple pages from both here and the oficial documentation but for some reason, it seems that there is no proper way to load a different kernel besides the one that comes from AWS.
Did someone from here had the same problems? Was there any workaround found?

root:/var/snap/amazon-ssm-agent/3552# modprobe snd-aloop
modprobe: FATAL: Module snd-aloop not found in directory /lib/modules/5.4.0-1045-aws

root:/var/snap/amazon-ssm-agent/3552# ls /lib/modules
5.4.0-1045-aws 5.8.0-45-generic 5.8.0-55-generic

root:/var/snap/amazon-ssm-agent/3552# uname -r
5.4.0-1045-aws

root:/var/snap/amazon-ssm-agent/3552# grep -A200 submenu /boot/grub/grub.cfg |grep menuentry
submenu ‘Advanced options for Ubuntu’ $menuentry_id_option ‘gnulinux-advanced-e8070c31-bfee-4314-a151-d1332dc23486’ {
menuentry ‘Ubuntu, with Linux 5.8.0-55-generic’ --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-5.8.0-55-generic-advanced-e8070c31-bfee-4314-a151-d1332dc23486’ {
menuentry ‘Ubuntu, with Linux 5.8.0-55-generic (recovery mode)’ --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-5.8.0-55-generic-recovery-e8070c31-bfee-4314-a151-d1332dc23486’ {
menuentry ‘Ubuntu, with Linux 5.4.0-1045-aws’ --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-5.4.0-1045-aws-advanced-e8070c31-bfee-4314-a151-d1332dc23486’ {
menuentry ‘Ubuntu, with Linux 5.4.0-1045-aws (recovery mode)’ --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-5.4.0-1045-aws-recovery-e8070c31-bfee-4314-a151-d1332dc23486’ {
menuentry ‘Ubuntu 20.04.2 LTS (20.04) (on /dev/xvda1)’ --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option ‘osprober-gnulinux-simple-e8070c31-bfee-4314-a151-d1332dc23486’ {
submenu ‘Advanced options for Ubuntu 20.04.2 LTS (20.04) (on /dev/xvda1)’ $menuentry_id_option ‘osprober-gnulinux-advanced-e8070c31-bfee-4314-a151-d1332dc23486’ {
menuentry ‘Ubuntu (on /dev/xvda1)’ --class gnu-linux --class gnu --class os $menuentry_id_option ‘osprober-gnulinux-/boot/vmlinuz-5.4.0-1045-aws–e8070c31-bfee-4314-a151-d1332dc23486’ {
menuentry ‘Ubuntu, with Linux 5.4.0-1045-aws (on /dev/xvda1)’ --class gnu-linux --class gnu --class os $menuentry_id_option ‘osprober-gnulinux-/boot/vmlinuz-5.4.0-1045-aws–e8070c31-bfee-4314-a151-d1332dc23486’ {
menuentry ‘Ubuntu, with Linux 5.4.0-1045-aws (recovery mode) (on /dev/xvda1)’ --class gnu-linux --class gnu --class os $menuentry_id_option ‘osprober-gnulinux-/boot/vmlinuz-5.4.0-1045-aws-root=PARTUUID=5198cbc0-01 ro recovery nomodeset dis_ucode_ldr panic=-1-e8070c31-bfee-4314-a151-d1332dc23486’ {

So was able to install different kernels but it seems I can’t change to take the generic ones, even after changing it as instructed here - https://docs.easyjitsi.com/docs/docker.

Any help would be appreciated.

Check this: Change default kernel in Ubuntu 18.04 – Linux blog

I have changed kernels, on Ubuntu(AWS EC2), multiple times, using this link…

Based on your ouput above, you’ll want to modify /etc/default/grub with:

GRUB_DEFAULT="gnulinux-advanced-e8070c31-bfee-4314-a151-d1332dc23486>gnulinux-5.8.0-55-generic-advanced-e8070c31-bfee-4314-a151-d1332dc23486"

Then run update-grub and reboot

It should come up the alternative kernel.

Edit: you might want to first check that /lib/modules/5.8.0-55-generic contains the snd-aloop module. IIRC, not all the kernel modules will have that module available.

1 Like

Manu thanks @shawn. Thank you very much for the quick response.

i did’t get you

modprobe snd-aloop this line still give me above error