Installed jitsi-meet in ubuntu, but unable to see video between systems in same LAN

After successful installation of jitsi-meet on ubuntu 18.04 by following the mentioned steps below, we able to create room and join between browsers in local host able to see video, but when we try connecting from other desktop of same LAN , We not able to access conference url by domain name but able to access by ip only and also we are unable to see video of other party once we connect through ip.

 1. enabled https/http and port 10000 to 20000 for udp
 2. installed openjdk-8-jre-headless
 3. installed ngnix and started as service
 4. Then executed
         wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -
         sudo sh -c "echo 'deb https://download.jitsi.org stable/' > /etc/apt/sources.list.d/jitsi-stable.list"
         sudo apt update -y
         sudo apt install -y jitsi-meet
             also we set hostname as jitsimeet.example.com and selected "Generate a new self-signed certificate"
 5. ran /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

Are we making any mistakes or missing configuration. Can some one help to view video between two desktops in same LAN.

Can you check your prosody logs for errors? Which prosody version do you use?
dpkg -l | grep prosody

if you have already jitsi-meet install then you can follow below link
https://jitsi-meet-ssl-certificates.blogspot.com/

ii jitsi-meet-prosody 1.0.3729-1 all Prosody configuration for Jitsi Meet
ii prosody 0.10.0-1build1 amd64 Lightweight Jabber/XMPP server

logs

Feb 07 11:42:15 mod_bosh info New BOSH session, assigned it sid ‘80185bc2-ca99-481e-8b06-8bdef3982c57’
Feb 07 11:42:16 bosh80185bc2-ca99-481e-8b06-8bdef3982c57 info Authenticated as e1624067-8523-4fb3-b988-d76fe32c436a@jitsimeet.example.com
Feb 07 11:47:27 bosh80185bc2-ca99-481e-8b06-8bdef3982c57 info BOSH client disconnected
Feb 07 13:24:25 mod_bosh info New BOSH session, assigned it sid ‘d43beee9-0638-4728-949d-b8eaf88795f0’
Feb 07 13:24:25 boshd43beee9-0638-4728-949d-b8eaf88795f0 info Authenticated as 6cb3301c-5957-4687-815b-5665008fab53@jitsimeet.example.com
Feb 07 13:25:36 boshd43beee9-0638-4728-949d-b8eaf88795f0 info BOSH client disconnected

@Raj_Yadav , i have followed similar steps to your first link as mentioned in installation steps in my issue , and have selected “Generate a new self-signed certificate” during jitsi installation . anything else we need to enable?

It is strange, these logs seems normal. A bosh connection is established and then as there were not further requests for that connection, it timeouts after exactly one minute, as 60 seconds is the default bosh timeout.
Can it be you have some outgoing traffic disabled in your firewall or something like that?

i dont think so , all relevant ports are listing in status
To Action From
– ------ ----
OpenSSH ALLOW Anywhere
80/tcp ALLOW Anywhere
443/tcp ALLOW Anywhere
10000:20000/udp ALLOW Anywhere
10000:20000/tcp ALLOW Anywhere
5222 ALLOW Anywhere
5347 ALLOW Anywhere
OpenSSH (v6) ALLOW Anywhere (v6)
80/tcp (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)
10000:20000/udp (v6) ALLOW Anywhere (v6)
10000:20000/tcp (v6) ALLOW Anywhere (v6)
5222 (v6) ALLOW Anywhere (v6)
5347 (v6) ALLOW Anywhere (v6)

any other logs i need to check, looks video path is having issue
we have 2 systems through router , anything related to NAT we need to configure?

Hi
I resolved the issue, i removed the installation and followed
https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#systemd-details
and i gave ip address as domain name and followed your steps

    vi /etc/jitsi/videobridge/sip-communicator.properties

    **Put the below lines on sip-communicator.properties files** 

    # This line already added in sip-communicator.properties file be careful

    org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.domain<IP>.com/.*

    #you have to add from here

    org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false

    org.jitsi.videobridge.TCP_HARVESTER_PORT=4443

    org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=10.XX.XXX.14

    org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=50.12.XX.220

    org.jitsi.videobridge.ENABLE_STATISTICS=true

    org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub

    org.jitsi.videobridge.STATISTICS_INTERVAL=5000

    org.jitsi.videobridge.PUBSUB_SERVICE=pubsub.50.12.XX.220

    org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

thanks for help