Installation Problem on Linux Mint

Dear all,
I installed Jitsi Desktop out of the Ubuntu Repositories on Linux Mint 19 cinnamon. The application does not work, in the terminal I see a lot of missing things. Can anybody give me a hint? As a new user I am not allowed to upload a file and the text is limited. So I only attach an incomplete output.
Kind regards
Jürgen
~$ jitsi
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.apache.felix.framework.util.SecureAction (file:/usr/share/jitsi/lib/felix.jar) to method java.net.URLClassLoader.addURL(java.net.URL)
WARNING: Please consider reporting this to the maintainers of org.apache.felix.framework.util.SecureAction
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
org.osgi.framework.BundleException: Unable to resolve bcprov [109](R 109.0): missing requirement [bcprov [109](R 109.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.5.0))(&(osgi.ee=JavaSE)(version=1.6.0))(&(osgi.ee=JavaSE)(version=1.7.0))(&(osgi.ee=JavaSE)(version=1.8.0))(&(osgi.ee=JavaSE)(version=1.9.0))) Unresolved requirements: [[bcprov [109](R 109.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.5.0))(&(osgi.ee=JavaSE)(version=1.6.0))(&(osgi.ee=JavaSE)(version=1.7.0))(&(osgi.ee=JavaSE)(version=1.8.0))(&(osgi.ee=JavaSE)(version=1.9.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:844)
org.osgi.framework.BundleException: Unable to resolve org.jitsi.bccontrib [110](R 110.0): missing requirement [org.jitsi.bccontrib [110](R 110.0)] osgi.wiring.package; (osgi.wiring.package=org.bouncycastle.crypto.digests) [caused by: Unable to resolve bcprov [109](R 109.0): missing requirement [bcprov [109](R 109.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.5.0))(&(osgi.ee=JavaSE)(version=1.6.0))(&(osgi.ee=JavaSE)(version=1.7.0))(&(osgi.ee=JavaSE)(version=1.8.0))(&(osgi.ee=JavaSE)(version=1.9.0)))] Unresolved requirements: [[org.jitsi.bccontrib [110](R 110.0)] osgi.wiring.package; (osgi.wiring.package=org.bouncycastle.crypto.digests)]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:844)
org.osgi.framework.BundleException: Unable to resolve slf4j.api [113](R 113.0): missing requirement [slf4j.api [113](R 113.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0)) Unresolved requirements: [[slf4j.api [113](R 113.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:844)
org.osgi.framework.BundleException: Unable to resolve org.bitlet.weupnp [114](R 114.0): missing requirement [org.bitlet.weupnp [114](R 114.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) Unresolved requirements: [[org.bitlet.weupnp [114](R 114.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:844)
org.osgi.framework.BundleException: Unable to resolve org.jitsi.dnssecjava [115](R 115.0): missing requirement [org.jitsi.dnssecjava [115](R 115.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [113](R 113.0): missing requirement [slf4j.api [113](R 113.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[org.jitsi.dnssecjava [115](R 115.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:844)
org.osgi.framework.BundleException: Unable to resolve org.jitsi.jain-sip-ri-ossonly [104](R 104.0): missing requirement [org.jitsi.jain-sip-ri-ossonly [104](R 104.0)] osgi.wiring.package; (osgi.wiring.package=javax.net) Unresolved requirements: [[org.jitsi.jain-sip-ri-ossonly [104](R 104.0)] osgi.wiring.package; (osgi.wiring.package=javax.net)]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:844)
org.osgi.framework.BundleException: Unable to resolve org.opentelecoms.sdp.java-sdp-nist-bridge

You need java 8 to run it.

Thank you. I installed openjdk-11-jre , is this not compatible?