Installation on Ubuntu 18.04.4 not working

Hi all,
following the official quick guide the installation on Ubuntu 18.04.4 not work.
Tried also other guides to install it, with nginx, without it, using let’s encrypt, without it.
Reinstalling every time the server so the start situation was every time clean, but there is no way to make it work.
Nothing is listening on the port 80, and if you try the installation with the nginx, both nginx and the java process fight for the 443 port.

Something is really wrong in the installation guide.

Also trying to purge the package, the jitsi-meet-web-config is broken and to remove it You must go in /var/lib/dpkg/info and remove the related files to purge it.

Hi Davide, I just install on Ubuntu 18.04 and made it work. It is still in test but I may help you.

The use of sudo is optional. If you are loged via root, dont use it, its borring.

You first must uninstall everything. Following the reference; https://github.com/jitsi/jitsi-meet/issues/2663#issuecomment-376484424
Step 1
apt-get --purge remove jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config jicofo jitsi-videobridge
step 2
apt-get autoclean
step 3
apt-get --force-yes remove
step 4
apt-get install --reinstall dpkg
step 5
cd /var/lib/dpkg/info
step 6
sudo rm jitsi-meet-web-config.postinst

Then I did the following sequence using this nice tutorial: https://www.howtoforge.com/tutorial/how-to-create-your-own-video-conference-using-jitsi-meet-on-ubuntu-1804/

sudo apt-get update -y
sudo apt-get upgrade -y
Check that your domain-name is well configured into the /etc/hosts. In my case, I configured meet.my-domain.com associated to my IP address. You can use
nano /etc/hosts
and check after with
hostname -I #this will give only your domain name (FQDN)
sudo apt-get install -y openjdk-8-jre-headless -y
java -version # test it and you will get something like this
openjdk version “10.0.2” 2018-07-17
OpenJDK Runtime Environment (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.3)
OpenJDK 64-Bit Server VM (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.3, mixed mode)

If you have not yet installed NgInx ? Else skip but be aware that we will come back to it
apt-get install nginx -y
systemctl start nginx
systemctl status nginx

wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -
sudo sh -c “echo ‘deb https://download.jitsi.org stable/’ > /etc/apt/sources.list.d/jitsi.list”

Note: other installation create the file jitsi-stable.list. I have both with the same content in that directory. You may then:
cd /etc/apt/sources.list.d
cp jitsi.list jitsi-stable.list

sudo apt-get update -y
sudo apt-get upgrate -y # some tutorial forget this step.

sudo apt-get install jitsi-meet -y
An interactive GUI style 1980’ties will popup asking you your domain name for your jitsi-meet. In my case it was meet.my-domain.com. Enter it with attention else better start again everything.

Next the beautiful antique GUI will ask if you want a SSL certificate and that is up to you but better select this option from letsencrypt. This process will create many certificates into the app and into the directory of letsencrypt and change the NgInx sites-enable directory.
So its done !!

NOOO it is not !

Go into the NgInx sites-enabled directory (/etc/nginx/sites-enabled) and check your files. One is for Jitsi-meet. The Certificates that are linked are not sufficient to be recognized as a secured site. So change them with the one into the letsencrypt directory live:
Just get a look:
cd /etc/letsencrypt/live
ls
You shoud see a directory with your meet-domain name, here meet.my-domain.com.
cd meet.my-domain.com # put your domain !!!
ls
cert.pem chain.pem fullchain.pem privkey.pem README
You must link the fullchain.pem and the privkey.pem in your NgInx site-enabled config file that must have the same meet-domain name.

RSA certificate

ssl_certificate /etc/letsencrypt/live/meet.iamtheowner.com/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/meet.iamtheowner.com/privkey.pem;

Firewall configuration;

ufw allow ssh
ufw allow http
ufw allow https
ufw allow in 10000:20000/udp

If you have Webmin on port 10000, you must change it for another port, may be 9999, via the Webmin > Webmin Configuration > Port and Adress icon. Previously to that, you must already have the remote access via SSL for root or other login pertaining to the sudo group.

May be it is all. Good luck.

Above command will clearly uninstall jitsi. But it will not remove previously configured ssl keys or config files.

Thank You, I’ve reached the situation that the service start and listen on the ports, i can connect on the web, but when a third user is connected on the room all audio video stop working.

Resolved, installing it on debian 10, worked on the first restart.