Installation of Jitsi and integration with jibri

Hi,
Im new of using linux and set upping. I set up Jitsi a few days ago it was working well. Now im trying to set up jibri. It is on my pc but i couldnt integration them.
jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2020-07-06 16:30:29 +03; 19h ago
Main PID: 1523 (java)
Tasks: 33 (limit: 4428)
Memory: 147.7M
CGroup: /system.slice/jibri.service
└─1523 java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -j

Jul 06 16:30:30 pardus4 launch.sh[1523]: at java.util.logging.LogManager$RootLogger.a
Jul 06 16:30:30 pardus4 launch.sh[1523]: at java.util.logging.Logger.getHandlers(Logg
Jul 06 16:30:30 pardus4 launch.sh[1523]: at java.util.logging.Logger.log(Logger.java:
Jul 06 16:30:30 pardus4 launch.sh[1523]: at java.util.logging.Logger.doLog(Logger.jav
Jul 06 16:30:30 pardus4 launch.sh[1523]: at java.util.logging.Logger.log(Logger.java:
Jul 06 16:30:30 pardus4 launch.sh[1523]: at java.util.logging.Logger.info(Logger.java
Jul 06 16:30:30 pardus4 launch.sh[1523]: at org.jitsi.jibri.MainKt.main(Main.kt:87)
Jul 06 16:30:30 pardus4 launch.sh[1523]: SLF4J: Failed to load class "org.slf4j.impl.StaticLo
Jul 06 16:30:30 pardus4 launch.sh[1523]: SLF4J: Defaulting to no-operation (NOP) logger imple
Jul 06 16:30:30 pardus4 launch.sh[1523]: SLF4J: See http://www.slf4j.org/codes.html#StaticLog

it set up on local IP, im getting error like that. I don’t know if it is because I installed it on the IP

prosodyctl check config


A problem occurred while reading the config file /etc/prosody/prosody.cfg.lua

Error: /etc/prosody/prosody.cfg.lua:219: syntax error near ‘register’

More help on configuring Prosody can be found at https://prosody.im/doc/configure
Good luck!


work that nano /etc/prosody/prosody.cfg.lua

prosodyctl register jibri auth.172.18.1.45 jitsi
prosodyctl register recorder recorder.172.18.1.45 recorder

Did you add these lines to prosody.cfg.lua? If so, this is not right. These are the shell commands using to add some accounts.

yes i did but after i remove all of things on computer and set up all of them again. run that on terminal and they worked. It is done but now after installation of jibri i cant start a meeting on jitsi