Installation mess in Ubuntu 18.04: no /etc/jitsi folder anymore

Hi!
I think a made a mess… in order to re-start the installation from scratch in Ubuntu 18.04 Desktop, I removed /etc/jitsi folder, thinking that the new installation would have rebuilt it.
But now I have no /etc/jitsi folder anymore…

How to recover?

looking forward to your kind help

Check the quick install guide and the uninstall instructions and start from scratch.

Re-installation seems going smoother now. Thanks.

May I ask you one more question about /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh ?

:+1:

I’m developing my web-electron app locally, registered a domain for which I have already a Let’s Encrypt certificate,

(base) marco@meet:~$ sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

This script will:

  • Need a working DNS record pointing to this machine(for domain meet.my.domain)
  • Download certbot-auto from https://dl.eff.org to /usr/local/sbin
  • Install additional dependencies in order to request Let’s Encrypt certificate
  • If running with jetty serving web content, will stop Jitsi Videobridge
  • Configure and reload nginx or apache2, whichever is used
  • Configure the coturn server to use Let’s Encrypt certificate and add required deploy hooks
  • Add command in weekly cron job to renew certificates regularly

You need to agree to the ACME server’s Subscriber Agreement (https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf)
by providing an email address for important account notifications
Enter your email and press [ENTER]:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for meet.my.domain
Using the webroot path /usr/share/jitsi-meet for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. meet.my.domain (http-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up A for meet.my.domain - check that a DNS record exists for this domain

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: meet.my.domain
    Type: None
    Detail: DNS problem: NXDOMAIN looking up A for meet.my.domain -
    check that a DNS record exists for this domain

I already inserted a A + Dynamic DNS Record for meet.my.domain in the namecheap.com configuration settings where Dynamic DNS Record for my.domain is present.
And I’ve already put in /etc/hosts : xxx.xxx.xxx.xxx meet.my.domain
What else have I do for meet.my.domain ?

If you already have a certificate, why are you running it again?

Do you mean that I can use Let’s Encrypt certificate of “my.domain” ?

If you already have a certificate, for a domain, which you will be using to install jitsi, then no need to run letsencrypt again. Simply use the existing one.

Edit: I got it. You want cert for a sub domain. Think it should work as long meet.my.domain resolves to the server properly.

Make sure port 80 is open on server and also forwarded properly if behind a NAT.