Installation issue on ubuntu paltform

Hi…
I am trying to install jitsi-meet as given in instruction manual,
but encountering this issue:
The following packages have unmet dependencies:
jitsi-meet : Depends: jitsi-meet-prosody (= 1.0.3969-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
I tied installing prosody but it itslef come up with lot of dependencies issues.
Can somebody helps me on how to resolve this issue ?

Do you have universe repo added?

I have the same problem and universe repo added…

yes…inspite of that the issue persist.