Installation failing, can't get smart out of error logs in jigasi

I followed the standard installation guide for jitsi for ubuntu 18 and it’s working correct.
Now i’m trying to add jigasi support with SIP.
I have tried a few things, reinstalling etc. but nothing seems to work. I’m pretty sure my sip details are working as I downloaded the jitsi desktop app and add a sip account and I’m able to call my mobile with the sip number using jitsi desktop. I’ve done some research and I can’t find a solution. In my jitsi meet instance I can’t see any new function for sip integration, like a mentioned plus on the toolbar or something. I checked my jigasi error log and copied the relevant “SEVERE” issues. Can someone help me figure this out?
All I did was apt-get install jigasi and entered my sip details. Is the rest done automatic by default?

2020-08-23 12:38:47.638 INFO: [10] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() fail$
$eating c lib instance for fixing file permissions
java.nio.file.FileSystemException: /etc/jitsi/jigasi: Operation not permitted

SEVERE: [10] org.jitsi.impl.neomedia.device.DeviceConfiguration.log() Faile$
java.lang.IllegalStateException: audioSystem

2020-08-23 12:40:03.765 SEVERE: [62] org.jivesoftware.whack.ExternalComponentManager.error() Broken pipe (Write failed)

Broken pipe error is the last thing to display.
I’m more than willing to provide more error logs or anything that could help some fix this.
Any help is much appriciated. Thanks

This is your problem, the others you can ignore. The jigasi cannot connect as component. The recommended way is to use control mucs. try that.

Alright. I seem to have managed to removed all issues from the jigasi log. I can’t see anything in the webinterface though. Found following in console:
2020-08-23T17:35:15.050Z [modules/xmpp/moderator.js] <u.parseConfigOptions>: Sip gateway enabled: false, does that help?

Seems to brake back down to this issue. Is their any other possible solution? I’m finding it quite hard to understand brewery as a none linux guy. Can I fix the default call control?