Installation and setup jitsi-meet and videobridge

I need to install jitsi-meet-web, jicofo, jitsi-meet-web-config, jitsi-meet-prosody on Server A and jitsi-videobridge on Server B with proper connectivity.
I tried some ways but they are not working.
Please guide with proper steps.

Thanks in advance

It will probably be easier for others to help if you describe what you’ve tried and how it is failing.

Btw, have you seen this? DevOps Guide (scalable setup) · Jitsi Meet Handbook

I followed these commands-

For Server A
$ sudo apt update
$ sudo apt install jicofo
$ sudo apt install jitsi-meet-web
$ sudo apt install jitsi-meet-web-config
$ sudo apt install jitsi-meet-prosody

It will ask for the hostname - enter the hostname of the Jitsi-meet server (this server)
It will also ask for the Jitsi video-bridge server’s password - Enter any password (for example-> JVB_key)

Obtaining a Signed TLS Certificate:
sudo add-apt-repository ppa:certbot/certbot
sudo apt install certbot
sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

For Server B-

  $ sudo apt update
  $ sudo apt install jitsi-videobridge2

during the installation it asks for a hostname, please use your jitsi-meet.server.domain there (it will fill the configs almost complete)

edit /etc/jitsi/videobridge/sip-communicator.properties with the following values (the other values have to stay as they are):

org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=jitsi_meet_server_domain
org.jitsi.videobridge.xmpp.user.shard.PASSWORD = JVB_key

Now restart videobridge
$ systemctl restart jitsi-videobridge2

And the error you see in the logs is?

While joining meet link i got this in jicofo log

And i got this in jvb log

Is TCP/5222 open on JMS?

In my opinion, first install the whole system on JMS then add the additional JVB later. Compare the JVBs’ configs. If everything is OK, disable JVB on JMS using systemctl

1 Like

Failed to login. Disconnecting to trigger a re-connect.

The last time I saw that error, it was a case that JVB can reach prosody but org.jitsi.videobridge.xmpp.user.shard.PASSWORD was incorrect.

Just in case, perhaps double-check that what you have there matches password for “jvb” user in prosody?