Install on virtual server with plesk

Hi,
I have installed Jitsi on a virtual server (Ubuntu 16) via console according to the jitsi video tutorial without failure. The DNS A record of the subdomain ist set to the IP in the DNS settings of the domain.
The subdomain was installed with plesk and is accessiable (http: and https: Lets encrypt) but points to the webspace generatet with plesk.
Can somebody give me a hint please?

Hi,
I have the same question. I also installed Jitsi on Plesk with Ubuntu 18.04.4 LTS‬. How can I access the Jitsi Installation? Because the Installation from Jitsi is not in the Webspace that Plesk installed by installing the subdomain.
Thanks a lot for any answers.

Hi Jitsi community,
I’m in the same boat on Debian 9 with Plesk Obsidian 18.0.26

I’ve found a potential solution from @sparviere :
https://community.jitsi.org/t/noob-question-url-shows-plesk-admin-interface-instead-of-jitsi-org/23802/8
I will try it later today and if it doesn’t work, I’ll try my luck with jitsi meet on docker.

For plesk users it would be ideal to use a plesk extension (like nextcloud) or jitsi in docker.
And I would actually prefer to use docker, but instead of one image in the repositiory, there are a few docker images (https://hub.docker.com/u/jitsi/) and I don’t know how to configure them all in plesk :thinking:
I’d be most grateful to anyone providing us a tutorial or some advice on how to install and configure jitsi-meet on plesk / jitsi-meet in docker (running on plesk).
Thank you.

You should try copying the jitsi-meet directory that’s under /usr/share/ in your vhost directory. You need to tell Plesk that your home directory is the jitsi-meet folder because plesk doesn’t allow you to choose a subfolder that’s not in the vhost folder. So, after you copied the directory, you can set it as your home directory in Plesk under your domain, “Hosting Settings” -> “Document Root”

I’m sure that there is a better solution than this, but I didn’t have much time nor enough Linux expertise to find it.

1 Like