Install Jitsi on to run at localhost and a certain port

Hi everyone,
I would like to install jitsi on VPS and I am having some difficulty to install it. I am not a very expert server admin, so I may use wrong terminology or say wrong things. Please have patience with me.

Most of the services I instal on the server run on localhost at a certain internal port, let’s say localhoost:Y. I then select a port Xand configure VirtualHost in apache to get the service reachable at The SSL comes from

The standard installation procedure of Jitsi, however, has instead a few steps involving changing the /etc/hosts, setting up a FQDN, and the request during installation to define a hostname for the Videobridge, while I would simply like to run it at localhost:Y.

Would it be possibile to install that way? I simply do not want to define a domain name and a dedicated SSL key for Jitsi but just use a port and domain’s SSL. Thank you very much!

It should be possible but makes things more complicated.

You may install jitsi-meet with nginx after stopping apache, update nginx ports to allow it to run with apache concurrently and point the same certificates in nginx config.

@emrah thank you for your answer, I do not think I would know how to do it. It is not clear to me why I should install it with nginx instead of simply make it run listening to a port in localhost.

Because jitsi is not a single service that listens only one port, it is a collection of multiple services with many ports and nginx is already configured according to these dependencies. IMO this is more easier.

@emrah So, I reinstalled jitsi using now the server IP and selecting Generate a new self-signed certificate to bypass the SSL issues. Now this works at the IP of the server, which is nice enough :slight_smile: But I guess it is using port 80 (there is no SSL right now) and I would still like to change the port. I did not find a port setting in the config.js file. Perhaps I have to define it in the domain name? e.g.

Perhaps I should ask this in another, but how to stop/start jitsi?

I tried stopping the following services in systemctl: prosody, jicofo, jitsi-videobridge2, but jitsi is still running.

If you have stopped prosody, jicofo and videobridge, what remains is the web server serving the web page. So in fact jitsi is not running, but only its web page is being displayed. If you want to stop that, stop the web server (nginx or apache) or reconfigure it to not serve the jitsi virtual host.