Install Jitsi on Synology NAS

Hello all.

Anyone of you successfully managed to install Jitsi Meet server on a synology NAS? Through the Synology “app store”, it is possible to run Docker, but not Docker Compose. I am not a Docker expert and therefore would be looking at some feedback from experts here to identify if it is even possible to run jitsi on a Synology NAS?

Thank you all and stay safe,
Lyononline

These people managed to install it: Jitsi, Dockers and Synology NAS

You actually can use docker-compose on a Synology NAS. It’s a command line utility, so you don’t run it from the web gui.

Why not simply use the new Jitsi Package I created and published?
It can be found on Community Package Hub as a signed Package: https://www.cphub.net/?p=jitsimeet (just add this package source to get updates)

Sorce code is on github in examples/synology directory here https://github.com/TosoBoso/docker-jitsi-meet/tree/synology/examples/synology which is forked from jitsi.
I already raised a pull request. but currently it is not merged in and kept separate.

Check it out, it just works, installs and orchestrates all via UI, nice features incl. no need to ssh for commands as it has an admin-gui.
An important feature: jitsi needs to know its public IP which has to be set as DOCKER_IP_ADRESS in the env and this package automates this at startup. So if you router changes IP each night just schedule a package restart each morning

PS: by definition it will only work on x64 NAS, the + models supporting Docker
-TosoBoso

All ok just I cannot start recording
Start container jitsi_jibri failed: {“message”:“linux runtime spec devices: error gathering device information while adding custom device “/dev/snd”: no such file or directory”}.
@TosoBoso any troubleshooting to that?

Hi, this is a Jitsi limitation on Docker see: https://github.com/jitsi/docker-jitsi-meet/issues/721
I cannot troubleshoot nor resolve this as Synology simply and does not have the package and /dev/snd and unlike default (Debian) Unix Alsa loopback it cannot be added. I concur with issue description above that this is a unneccessary dependecy and to be resolved ‘upstream’ by Jitsi Team. Note this is outlined during install (Jibrii recording experimental) and in the FAQ of the package when you select intro.
-TosoBoso

TosoBoso, does it can be solved by adding USB Soundcard stick to synology and pass it to docker as /dev/snd ?

Hi TosoBoso,

I installed the docker file and it works great. The only challenge I face right now is that Android apps and desktop apps can not use the Jitsi instance. It seems that the needed ssl ciphers described in the ngx folder are different than the ones used for the working instance of meet.jit.si . Some users solved it in modifying the ssl.conf but regardless what I do it is being reset to the defaults whenever I restart the docker images.
Can you point me to the process how to change the default files and to add other options to the config files in a persistent way?
PS: the Jitsi app in IOS does not face the problem and in view of the desktop app we can not use the x-frames)
-Thorsten-

Dear Tosoboso, I really appreciate your work, unfortunately the Synology program won’t start. When I look at the docker UI there is no container at all installed. During install process all docker files will be downloaded but none will be installed. What am I doing wrong? Are there any remnants from older installation trials?

  • oxygenetic

Dear Tosoboso,

I included your link in the package center, found your jitsi spk but when i want to download it it says, cant download

Can you share the spk file please?

Hello. I am a new Synology player. I installed the TosoBoso’s Jitsi Package. But I don’t know how to turn the Jitsi meeting on. My Synology is DS1621+. Thanks a lot.