Install jibri and connect success but recording faile to start

#1

Hi Team

I am trying to install jibri in docker

when i check log jibri, i seen status connected:
Xmpp connection status: connected

when i check log jicoro, i seen info available : true

i thing connect is success but when i click start recording and check log jibri i seen ffmpeg running but it 's not work

My jibri log:

2019-02-28 08:59:08.993 SEVERE: [40] org.jitsi.jibri.capture.ffmpeg.executor.FfmpegExecutor.isFfmpegHealthy() Ffmpeg is running but doesn’t appear to be encoding:
2019-02-28 08:59:09.995 SEVERE: [40] org.jitsi.jibri.capture.ffmpeg.executor.FfmpegExecutor.isFfmpegHealthy() Ffmpeg exited with code 1. Its most recent output was hw:
2019-02-28 08:59:09.996 SEVERE: [40] org.jitsi.jibri.capture.ffmpeg.FfmpegCapturer.start() Ffmpeg already exited
2019-02-28 08:59:09.997 SEVERE: [40] org.jitsi.jibri.capture.ffmpeg.FfmpegCapturer.start() Ffmpeg started up but did not start encoding after 15 tries, giving up
2019-02-28 08:59:09.997 SEVERE: [40] org.jitsi.jibri.service.impl.FileRecordingJibriService.start() Capturer failed to start

#2

Hi @tungns4-topica,

Looks like the selenium session does not get connected. And also Jibri in a docker is experimental. Right @saghul? I read your post related to this somewhere I don’t recall

Abhijit

#3

The PR hasn’t been merged yet, so it’s as experimental as it gets!

#4

Hi Team

I fixed that error, but I have got another one. When clicking “Record” button and reading log, I see:

org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Visiting url https://vcrxtopkid-qa.topica.vn/111#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME=“Jibri”

org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Timed out waiting for call page to load

I tried to config in prosody:

c2s_require_encryption = true

consider_bosh_secure = true

but still got timeout when starting record

While I had no problem when putting url from browser.

Thanks for your support!

#5

Hi @tungns4-topica,

Do c2s_require_encryption = false in the prosody config.

Even I faced a similar issue. See this thread: [SOLVED] Jibri with JWT token enabled Jitsi

This solved my issue.

Abhijit

#6

Hi abhijitnathwani

i was setting c2s_require_encryption = true in general config prosody, in domain.cfg.lua I was setting c2s_require_encryption = false

But it doesn’t work :frowning:

#7

Hi @tungns4-topica,

It should be false in both the configs. That worked for me.

Abhijit

#8

Hi @abhijitnathwani

i was config c2s_require_encryption = false in general config prosody and domain.cfg.lua but it doesn’t work :frowning:

#9

@tungns4-topica Do you see any error on the JS console?

#10

@abhijitnathwani i see org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Timed out waiting for call page to load and no more error

#11

On the browser console?

#12

@abhijitnathwani you can join link : https://vcrxtopkid-qa.topica.vn/111#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME=“Jibri”

to see console.log :smiley:

#13

it’s a example about my jibri :smiley:

#14

@abhijitnathwani

I am trying to install jibri in docker, if it’s work, i thing i can auto scale jibri :smiley:

#15

Ohh. No idea about Jibri on Docker. @bbaldino or @damencho can suggest something as you have reached till this point.

#16

@tungns4-topica Can you please share your ffmpeg.0.txt
file log ?. This can help to find out if there is any on FFmpeg side.