Install instructions including domain set-up and ip numbers

Hello All,
I work for a University and we do a lot of health care work in Africa, therefore we do a lot of discussions with remote colleagues via various packages such as Zoom, sfb, or skype. I would like to set up jitsi server for trial, in case our regular methods quit or get overloaded. I have a good Xeon, Ubuntu server at home, behind a router, with a fixed ip address from my internet provider, and have purchased a suitable domain name. I can download and install source code, packages, or executables quite successfully but I’m not familiar with the granular networks setup stuff. Is there an install howto somewhere that covers the safe robust network setup stuff? Thanks a bunch. J

Thanks for this. I got as far as installing jitsi-meet-prosody and then get the “The given hostname does not exist” error. I think I have both apache and Nginx installed, which might be the cause of the problem. How can I debug and fix the problem. J

What hostname did you put in when prompted by the installation?

Thanks Neil, It never asked me for a hostname or domain name but I did try to set up both manually before doing the jitsi install. I suspect either the hostname or the domain name or both, and not in the correct file for configuration? Thx, J

If you purge the jitsi installation and repeat it, it should prompt you for the hostname for your jitsi service as part of the initial config.

Ubuntu 18.04 here, did this

sudo apt purge --auto-remove jitsi-meet

then this
sudo apt install apt-transport-https
and it told me it was already the most recent version, then this

sudo apt update then this

sudo apt -y jitsi-meet and still get the same error at

Setting up jitsi-meet-web (1.0.3969-1) ...
Setting up jitsi-meet-prosody (1.0.3969-1) ...
debconf: Unable to initialise frontend: Dialog
debconf: (Dialogue frontend requires a screen at least 13 lines tall and 31 columns wide.)
debconf: falling back to frontend: Readline
The given hostname does not exist in the config
The given hostname does not exist in the config
dpkg: error processing package jitsi-meet-prosody (--configure):
 installed jitsi-meet-prosody package post-installation script subprocess returned error exit status 1
Setting up jicofo (1.0-541-1) ...
debconf: Unable to initialise frontend: Dialog

Any suggestions where to go next? Thx.

For some reason, apt / debconf is not showing you the screen which lets you specify the hostname, so you cannot do it interactively.

You could try this, replacing meet.domain.com with your hostname:

echo ‘deb https://download.jitsi.org stable/’ >> /etc/apt/sources.list.d/jitsi-stable.list
wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -

echo “jitsi-videobridge jitsi-videobridge/jvb-hostname string meet.domain.com” | debconf-set-selections

echo “jitsi-meet-web-config jitsi-meet/cert-choice select ‘Generate a new self-signed certificate (You will later get a chance to obtain a Let’s encrypt certificate)’” | debconf-set-selections

apt-get --option=Dpkg::Options::=–force-confold --option=Dpkg::options::=–force-unsafe-io --assume-yes --quiet install jitsi-meet

1 Like

Thanks again Neil, making some progress.
First of all, none of these commands work unless logged in as root. Is that normal? I thought sudo should work?
Next, the line "echo "jitsi-meet-web-config … " doesn’t work, for bash shell anyway, unless you escape the brackets ( “()” ) with an escape character, as in “\(”
Finally, the last line that starts apt-get, I get this error message

 apt-get --option=Dpkg::Options::=–force-confold --option=Dpkg::options::=–force-unsafe-io --assume-yes --quiet install jitsi-meet
E: Type ‘‘deb’ is not known on line 2 in source list /etc/apt/sources.list.d/jitsi-stable.list
E: The list of sources could not be read.
E: Type ‘‘deb’ is not known on line 2 in source list /etc/apt/sources.list.d/jitsi-stable.list
E: The list of sources could not be read.

Next suggestion? Thanks a bunch.

[quote=“jamaas, post:9, topic:28632”]
First of all, none of these commands work unless logged in as root. Is that normal? I thought sudo should work?[/quote]

I’d have thought so.

This could be a character issue on this forum. If you replace the quote marks and asterisks with ’ and " as typed on my keyboard, it works for me, but if I type those characters here, it converts them into ones which do not work. Perhaps it’s my fault for not using code quotes here. e.g.:

echo "jitsi-meet-web-config jitsi-meet/cert-choice select 'Generate a new self-signed certificate (You will later get a chance to obtain a Let’s encrypt certificate)'"

No idea, I’m afraid.

why would the second attempt yield a different result than the first?

thanks btw for responding to my question of Saturday on this problem.

At any rate, I think that this problem is common and that we should have a document dealing with it. If you send me a rough draft or just notes for the solution, I will produce the document and send you the result. My email address is kloro2006@gmail.com.

The second attempt at what?

the second attempt at the server installation. I was replying to your
message to jamaas:

If you purge the jitsi installation and repeat it, it should prompt
you for the hostname for your jitsi service as part of the initial
config.

the second attempt at the server installation

Aha.

In which case, the jitsi packages are being updated regularly at the moment, to try to squash bugs. It’s possible that this is one of the bugs which was squashed, and so reinstalling — actually, installing a newer version — might work when the previous version did not.

I would be happy to help you with that and/or see if we can find the source of the problem. It could well be something unique to my computer system? Thx. J

I think the problem arises from the top line in the letsencrypt-cert.sh file.

debconf-show jitsi-meet-web-config | grep jvb-hostname

When I run it at the command line, it will only work when logged in a su BTW, it does in fact return the wrong host/domain name. What is the jvb-hostname, where is it stored, and how can it be changed/updated? Thx. J

got it. thanks again for your reply. very helpful.