Install as non-admin


I’m trying to install the jitsi outlook meet plugin.

It works fine, if I install it under a user that is local admin on the machine.

The problem is, that I want to deploy it through ConfigMgr/Intune and that installs as system and the users are NOT admins on their local machines.

Is there a way to install this, so it will work for all users?

It does not work, if I install it as an admin user and log in as an non-admin user after.

Kind regards

1 Like

@horymury do you know if this is possible?

We have the exact same problem. How do you deploy this to 2000 machines? Give them all administrator-rights? Narhh….don’t think so :-).

Cross my fingers for an answer.

Just to clarify, do you refer to this one?

The msi is configured to be installed for all users ( per machine) so it requires admin rights.
I’m not familiar with ConfigMgr/intunes but I manged to successfuly install it from a command prompt ran under System account.

  1. Started a cmd as admin:
  2. Used psexec (PsExec - Sysinternals | Microsoft Learn) in order to start a command prompt under System account as seen in the screenshot on step 1 (psexec -i -s cmd.exe)
  3. Install the plugin using the msi on the System account command prompt:

    For remote install, I would suggest using /qn ( no ui) instead of /qb (basic ui)
    msiexec /i [path/to]/8x8MicrosoftIntegration.msi /qn

Following the above, I have the plugin working in Outlook on both my admin and my non-admin accounts.

I’m pretty sure that most remote install tools allow starting command prompts under System account and running commands, eg I used sysinternals myself some time ago for remote installs. But I think that starting command prompt as an admin account instead of System sould work too.

Hope this helps.

Great that that msi file works for you, but it’s not that plugin, we are trying to install.

MSI file is called: JitsiMeetOutlook-v0.7.0-windows-anycpu.msi and THAT doesnt work for all users, even if we are installing it as SYSTEM account with psexec or configmgr/intune.

So your suggestion wont help us much, as this is also normally how we install other MSI’s, but this one is “one of a kind” to be gentle :wink:

Any other suggestions? And what is 8x8MicrosoftIntegration?

Ok found it:

This does not seem to be an official Jitsi or 8x8 add-in, however I might have a solution for you.

I had a look on the project in github and I think I identified the issue.

The msi does install per all users ( per machine) as expected, but the registry entries which the installation setup are on HKCU (HKEY CURRENT USER) - so that explains why only the user which installs it have it actually working:

And since when installed under the SYSTEM user, basically it will install under the SYSTEM HKCU, so won’t work for any normal logged in user.

So I did a patch .reg file which sets the same thing under the same relative registry path, but under HKLM ( HKEY LOCAL MACHINE)

So please create a .reg file and paste this code and then run the .reg:

Windows Registry Editor Version 5.00

"Manifest"="file:///C:\\Program Files (x86)\\JitsiMeetOutlookAddIn\\JitsiMeetOutlookAddIn.vsto|vstolocal"

This will result in this registry entry being created:

Notice the HKEY LOCAL MACHINE path .Since now we have it under HKLM, any logged in user’s Outlook should ‘see’ it.


After uninstalling the plugin ,this new entry need to be manually removed from registry - or to create and run a .reg file which deletes it - since the installer only cleans up the registry entries which it created! Otherwise you’ll get an error on Outlook startup as it won’t find the file mentioned under Manifest registry key since it will be removed by the uninstall.

In my test this worked, please give it a go.


What is the official jitsu plugin installer then? This is from their webpage :slight_smile:

The registry does not work, even though it is in add/remove programs and the registry entries are added.

We run Office 2016, if that does any difference.