Install allowners prosody module

Hey everyone,

I am kind of struggling to install the mod_muc_allowners.lua Module for Prosody. https://github.com/jitsi/jitsi-meet/blob/master/resources/prosody-plugins/mod_muc_allowners.lua

My Goal is to allow everyone to kick everyone from the conference and to start/stop recordings.
I already figured out I have to patch prosody to make kick functionality working.
Nonetheless I think I already installed the mod_muc_allowners.lua module but only the first participant to join shows the start indicating the owner feature.

What I did was: I copied the mod_muc_allowners.lua file to /usr/lib/prosody/modules and edited my prosody config in /etc/prosody/conf.avail/ yoursite .cfg.lua.
Any further steps I have to take?

An Lateron, what exactly do I have to do to -manually per hand- update the prosody patch for the kick functionality?

Thanks in advance and Greetings,
Jan

Did you restart prosody?
Do you see errors in prosody logs?

I did restart my whole server that should do the job right?
I will attach my logs but they don’t seem off to me, just some port binding errors.

Errorlog:

Jun 16 15:12:55 portmanager error Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

Jun 16 15:12:55 portmanager error Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

Jun 16 15:21:39 portmanager error Failed to open server port 5222 on ::, check that Prosody or another XMPP server is not already running and using this port

Jun 16 15:21:39 portmanager error Failed to open server port 5222 on *, check that Prosody or another XMPP server is not already running and using this port

Jun 16 15:21:39 portmanager error Failed to open server port 5269 on ::, check that Prosody or another XMPP server is not already running and using this port

Jun 16 15:21:39 portmanager error Failed to open server port 5269 on *, check that Prosody or another XMPP server is not already running and using this port

Jun 16 15:21:39 mod_posix error Danger, Will Robinson! Prosody doesn't need to be run as root, so don't do it!

Jun 16 15:21:39 mod_posix error For more information on running Prosody as root, see http://prosody.im/doc/root

Jun 16 15:21:39 mod_posix error Another Prosody instance seems to be running with PID 996, quitting

Jun 16 15:21:39 portmanager error Failed to open server port 5280 on ::, check that Prosody or a BOSH connection manager is not already running

Jun 16 15:21:39 portmanager error Failed to open server port 5280 on *, check that Prosody or a BOSH connection manager is not already running

Jun 16 15:21:39 portmanager error Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

Jun 16 15:21:39 portmanager error Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

Jun 16 15:21:39 portmanager error Failed to open server port 5347 on 127.0.0.1, this port is in use by another application

Jun 16 15:21:39 portmanager error Failed to open server port 5347 on ::1, this port is in use by another application

Jun 16 15:31:06 portmanager error Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

Jun 16 15:31:06 portmanager error Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

Normal Logs:

Prosody is using the select backend for connection handling

Jun 16 15:31:06 portmanager info Activated service ‘c2s’ on [::]:5222, :5222

Jun 16 15:31:06 portmanager info Activated service ‘legacy_ssl’ on no ports

Jun 16 15:31:06 portmanager info Activated service ‘s2s’ on [::]:5269, :5269

Jun 16 15:31:06 mod_posix info Prosody is about to detach from the console, disabling further console output

Jun 16 15:31:06 mod_posix info Successfully daemonized to PID 997

Jun 16 15:31:06 portmanager info Activated service ‘http’ on [::]:5280, :5280

Jun 16 15:31:06 portmanager error Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

Jun 16 15:31:06 portmanager error Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

Jun 16 15:31:06 portmanager info Activated service ‘https’ on no ports

Jun 16 15:31:06 conference.jitsi.onlinetasks.net:muc_domain_mapper info Loading mod_muc_domain_mapper for host conference.jitsi.onlinetasks.net!

Jun 16 15:31:06 conference.jitsi.onlinetasks.net:muc_domain_mapper info Loading mod_muc_domain_mapper for host jitsi.onlinetasks.net!

Jun 16 15:31:06 portmanager info Activated service ‘component’ on [127.0.0.1]:5347, [::1]:5347

Jun 16 15:31:06 conference.jitsi.onlinetasks.net:muc_domain_mapper info Loading mod_muc_domain_mapper for host focus.jitsi.onlinetasks.net!

Jun 16 15:31:06 speakerstats.jitsi.onlinetasks.net:speakerstats_component warn speaker stats will not work with Prosody version 0.10 or less.

Jun 16 15:31:06 conference.jitsi.onlinetasks.net:muc_domain_mapper info Loading mod_muc_domain_mapper for host speakerstats.jitsi.onlinetasks.net!

Jun 16 15:31:06 conference.jitsi.onlinetasks.net:muc_domain_mapper info Loading mod_muc_domain_mapper for host internal.auth.jitsi.onlinetasks.net!

Jun 16 15:31:06 conferenceduration.jitsi.onlinetasks.net:conference_duration_component warn conference duration will not work with Prosody version 0.10 or less.

Jun 16 15:31:06 conference.jitsi.onlinetasks.net:muc_domain_mapper info Loading mod_muc_domain_mapper for host conferenceduration.jitsi.onlinetasks.net!

Jun 16 15:31:06 conference.jitsi.onlinetasks.net:muc_domain_mapper info Loading mod_muc_domain_mapper for host recorder.jitsi.onlinetasks.net!

Jun 16 15:31:07 conference.jitsi.onlinetasks.net:muc_domain_mapper info Loading mod_muc_domain_mapper for host localhost!

Jun 16 15:31:07 conference.jitsi.onlinetasks.net:muc_domain_mapper info Loading mod_muc_domain_mapper for host auth.jitsi.onlinetasks.net!

Jun 16 15:31:07 conference.jitsi.onlinetasks.net:muc_domain_mapper warn Session filters applied

Jun 16 15:31:07 c2s5565889be900 info Client connected

Jun 16 15:31:07 c2s5565889be900 info Stream encrypted (TLSv1.2 with ECDHE-RSA-AES256-GCM-SHA384)

Jun 16 15:31:07 c2s5565889be900 info Authenticated as jibri@auth.jitsi.onlinetasks.net

Jun 16 15:31:10 conference.jitsi.onlinetasks.net:muc_domain_mapper warn Session filters applied

Jun 16 15:31:10 c2s5565889f91b0 info Client connected

Jun 16 15:31:11 conference.jitsi.onlinetasks.net:muc_domain_mapper warn Session filters applied

Jun 16 15:31:11 c2s556588a13cb0 info Client connected

Jun 16 15:31:12 c2s5565889f91b0 info Stream encrypted (TLSv1.2 with ECDHE-RSA-AES256-GCM-SHA384)

Jun 16 15:31:12 c2s556588a13cb0 info Stream encrypted (TLSv1.2 with ECDHE-RSA-AES256-GCM-SHA384)

Jun 16 15:31:12 c2s556588a13cb0 info Authenticated as jvb@auth.jitsi.onlinetasks.net

Jun 16 15:31:12 c2s5565889f91b0 info Authenticated as focus@auth.jitsi.onlinetasks.net

Jun 16 15:31:12 focus.jitsi.onlinetasks.net:component warn Component not connected, bouncing error for:

Jun 16 15:31:13 jcp556588aa0b60 info Incoming Jabber component connection

Jun 16 15:31:13 focus.jitsi.onlinetasks.net:component info External component successfully authenticated

Maybe share your config. By default this is installed in “/usr/share/jitsi-meet/prosody-plugins/” and the plugins path is enabled with this: https://github.com/jitsi/jitsi-meet/blob/master/doc/debian/jitsi-meet-prosody/prosody.cfg.lua-jvb.example#L1

Here is my config: jitsi.onlinetasks.net.cfg.lua.txt (3.0 KB)

This is from /etc/prosody/conf.avail/jitsi.onlinetasks.net.cfg.lua

muc_allowners should be enabled only under the main muc component, conference.jitsi..... Try that and see whether there is any difference

No unfortunately not… Still no moderator rights (regardless of weather it’s kicking or more important for my purpose start/stop) the conference recording.
Logs didn’t change as far as I can tell. Same errors and warnings…

DO you have any other idea of what I could be doing wrong or why it’s not working?

@Ruunic90

To make all users moderators all you need is a few lines of code.

Give this a try.

1 - Create a new prosody mod file, call it “mod_muc_moderators.lua” and save it to /usr/share/jitsi-meet/prosody-plugins/ and put these lines in it:

local muc_svc = module:depends("muc");

function module.load()
    muc_svc.room_mt.get_affiliation = function (room, jid)
      return "owner";
  end
end

2 - Update your properties file:
sudo vi /etc/prosody/conf.avail/meet.domain.com.cfg.lua

Component "conference.meet.domain.com" "muc"
    . . .
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
	    "muc_moderators";
    }
     . . .

3 - Finally, restart prosody and jicofo:
sudo service prosody restart && sudo service jicofo restart

Hope this helps you.