instalation in vps

Good afternoon, can you help me, I installed on my ubuntu server on a vps, when starting more than one person in the meeting it gets the gray screen and it doesn’t work, just a video conference with two people is working, any topic that I can study? appreciate

1 Like

Helo My Friend.
Tutorial Install on Ubuntu 18.04 and configuration Firewall
Active SUB

Hi @feliperosolin.

On your VPS, can you check your network security.

You most likely have TCP 443 and 80 enabled.

But do you have UDP 10000 enabled?

-Simon

yes my friend, I have everything installed correctly I followed a step by step.

Look

To Action From


OpenSSH ALLOW Anywhere
80 / tcp ALLOW Anywhere
443 / tcp ALLOW Anywhere
10000: 20000 / udp ALLOW Anywhere
10000 / udp ALLOW Anywhere
OpenSSH (v6) ALLOW Anywhere (v6)
80 / tcp (v6) ALLOW Anywhere (v6)
443 / tcp (v6) ALLOW Anywhere (v6)
10000: 20000 / udp (v6) ALLOW Anywhere (v6)

when the third person enters the call, the screens are gray and no videos appear on any machine, when a person goes out it goes back to normal!

I followed a step by step, everything apparently installed correctly!

Which device is being used?
Mobile or Desktop?
Is your certificate self-signed?
Do you have any security rules? servers like aws have security rules that you must apply on the virtual machine.

my server is contabo with server in the united states, the only things i did is install as step by step, i don’t understand much and i don’t know if there are rules to be applied, nor i know how to see, both! using smartphone or notebook the problem is presented!

ah! the certificate is drawn according to the installation of the step by step like this!

check that your port 10000 works like this:

(server)
sudo systemctl stop jitsi-videobridge2
nc -l 10000 -u
(workstation)
echo "123" | nc -u (your public address) 10000

on the server screen should appear ‘123’.

I’m a beginner in linux! and I’m setting it up because I need the platform on my behalf and on my server, I ran the commands to no avail, maybe I did something wrong! anyway I appreciate the help that everyone is giving.

sorry, it is unclear what is the meaning of ‘no avail’. Could mean ‘command not found’ in this case that has no great meaning. If you can’t be more precise when you describe what is happening on your system, it’s useless to search for help on a forum.

I couldn’t execute the command!

Do you know how to use SSH?

use in some basic commands and following the steps, but nothing you don’t learn! I am studying. I even discovered a possible problem, but not being able to solve it this way too, see what’s in the documentation:

Advanced configuration

If the installation is on a machine behind NAT jitsi-videobridge should configure itself automatically on boot. If three way calls do not work, further configuration of jitsi-videobridge is needed in order for it to be accessible from outside.

Provided that all required ports are routed (forwarded) to the machine that it runs on. By default these ports are (TCP/443 or TCP/4443 and UDP/10000).

The following extra lines need to be added to the file /etc/jitsi/videobridge/sip-communicator.properties :

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

In most cases, jitsi works without needing this type of change.

Please describe your installation and environment better:

Are you on a dedicated server just for jitsi or are you running other services?

Are you using NGINX?

What type of SSL certificate?

Regarding permissions of the installation folders as they are set?

Have you checked all the requirements for Jitsi?

Required packages and repository updates
You will need the following packages:

gnupg2
sudo # only needed if you use sudo

In most cases, jitsi works without the need for this type of change.

Describe your installation and environment better:

Are you on a dedicated jitsi server or are you running other services?

JITSI ONLY

Are you using NGINX?

YES

What kind of SSL certificate?

LET´S ENCRYPT

Regarding the permissions of the installation folders as they are defined?

I DON’T KNOW TO LOOK AT PERMISSIONS

Have you checked all the requirements for Jitsi?

JUST FOLLOW STEP BY STEP

Required packages and repository updates
You will need the following packages:

gnupg2
sudo # required only if you use sudo

I USE SUDO

IF I GIVE YOU ACCESS, COULD YOU LOOK AT IT? CLEAR IF IT ISN’T TO CRASH

if you have made these changes, please run this command and let me know if it worked.

service jitsi-videobridge restart

Let’s try to solve it here.
If we can’t, I can even help

Failed to start jitsi-videobridge.service: Unit jitsi-videobridge.service not found.

I’m even thinking about resetting the server and starting all over again