Inactive users thumbnails in the filmstrip with more than 5 participants

Hello,

When I have more than 5 participants in the room and use filmstrip mode, the participants appear as inactive. When I change the title view to grid, it returns to normal. I checked the information on the js console and I got this:

2020-07-03T15:21:53.366Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onmessage>: Channel new last-n event: (5) [“c655d6f0”, “f6f05d5c”, “20aa1132”, “d53ddd54”, “b814f683”] {colibriClass: “LastNEndpointsChangeEvent”, endpointsEnteringLastN: Array(4), conferenceEndpoints: Array(5), lastNEndpoints: Array(5)}
Logger.js:154
2020-07-03T15:21:53.760Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onmessage>: Channel new last-n event: [“c655d6f0”] {colibriClass: “LastNEndpointsChangeEvent”, endpointsEnteringLastN: Array(0), conferenceEndpoints: Array(5), lastNEndpoints: Array(1)}

For some strange reason, the endpointsEnteringLastN: Array(0) goes to zero, even though I’ve set my LastN to 20 on config.js. I’m using the same version of jicofo, prosody and videobridge of meet.jit.si. I suppose that it’s a bug. I think it’s related to:


Any developer could confirm this? @damencho The same behavior happens in meet.jit.si (image attached).

Can anyone help me with this problem? I’ve verified that it’s happening even I use only with 2 participants. And it happens also on Jibri instance. @gpolitis Please, could the option org.jitsi.videobridge.TRUST_BWE=false fix it? I’ve checked that you related this option on others posts.

All participants turn inactive at the same time, including in an instance of the jibri, it does not seem to be something related to the network. And only in filmstrip mode.

Sounds strange, but don’t think we’ve gotten any other reports of this (or seen it ourselves). Are the (non Jibri) clients all on your computer?

@bbaldino thanks for your reply. Yes! And it’s happening with only 2 persons on the room as well, in filmstrip mode. I think it could be related to this post, I’m not sure: Videostream stopps and goes to Connection Status inactive

At first, I thought it could be something related to my computer or network, but it’s happening on Jibri as well, it’s frequently and randomly and in the latest versions of meet.jit.si. I am already using the latest stable version of the videobridge, jicofo, jibri and jitsi, the problem remains.

For me, I can’t simulate this problem in the grid view, only filmstrip mode.

Grid view vs. film strip is probably the best clue–otherwise I’d be tempted to say your clients are CPU-limited since they’re all on the same machine (which would affect Jibri as well since it’s on the sending side), but if grid view works then that seems like something different. @saghul @Hristo_Terezov any ideas?

do you use a customized jitsi-meet ?

Hello, what do you mean by a customized jitsi-meet? I run a jitsi-meet on my own instance, as well, but I didn’t make changes on code.

you said you do run vanilla versions of java and lua code, but you did not include explicitly javascript code. Now it’s not clearer what you are running exactly but we can assume that it’s either stable (debian or docker) or unstable (debian)

I’m running debian (on ubuntu 18.04) latest stable version.