Improving Video Quality

Greetings All,
We have installed Jitsi Meet and experiencing that the quality of video is not up to the mark.
Q) Do we all have to install Jitsi Video Conferring Bridge separately as well?

Would appreciate any suggestion and help in that matter.

Thanks
Babar

If you have installed jitsi-meet it installs and jvb. Do you see any errors in the js console?

Thanks for the reply. No it has installed well, but the video quality is not up to the mark. I would rate 6/10 for the video quality.
Any suggestions?

I’m asking about client js logs in the browser, do you see errors there.
You can also test in meet.jit.si at the same time with same participants to rule out local bandwidth problems.

Don’t see any logs there. But seems like the quality is a little better on meet.jitsi.

Q) From your experience do I have to do something different, design wise, some package to be installed, to boost up the video quality in general?

Don’t think so, quality depends a lot on bandwidth and quality of the Internet.

Thanks Damian for the reply.

Any suggestion on how to enable the moderator control? Are there any controls available that can be extended or any work around?

By default first participant is the moderator. You can enable secure domain, check the handbook and then only authenticated users will be moderators.

Can you please point me to the handbook?

Also in order to enable multiple recordings at a time, is there a guide book or precise steps to follow?

Thanks.

@Babar here’s the information for Secure Domain - Secure Domain setup · Jitsi Meet Handbook

As for recording, you need an instance of Jibri for each recording you want to do. To install Jibri, you can check out this guide - TUTORIAL - How to Install the NEW JIBRI

Thanks Freddie.
For my understanding, as an example: we have 20 recordings come by at the same time, in order to scale up automatically, what is the recommendation and if any go to document?

Thanks in advance.

Freddie,
I am having the issue of getting average video quality, lot of pixels appearing, which does not give a smooth view.
Can you please share your sight what to do and if possible share some settings to achieve the best video quality results.

Thanks in advance.

If you’re hosting on AWS, you can use their autoscaling tool to scale up/down as necessary. Do a search in the forum; quite a number of people have shared how they manage this in their own deployment.

As far as video quality goes, I’m unsure why you’re seeing pixelation. Does this happen when you have just 2 people on the call, 3 or more people on the call or all the time? I see per Damencho’s recommendation you’ve already confirmed the quality is better at meet.jit.si. So, if we’ve ruled out possible websocket issues, the only other suggestion would be to try and fine-tune your settings.

You can do the following:

  1. Adjust your video constraints in config.js. Play with different resolutions to see what works for you.
constraints: {
         video: {
            height: {
               ideal: 720,
              max: 720,
                min: 240
             }
        }
   },
  1. Lower the thresholds for higher video quality with the minHeightForQualityLvl property (also in config.js):
 minHeightForQualityLvl: {
         180: 'standard',
           360: 'high'
       },
  1. And lastly, IF you only have a few people in your meetings and you’re certain everyone’s system (bandwidth especially) can handle it, you can also disable simulcast. Note that this is not really recommended as it puts a real strain on your bandwidth. But it will give you the best quality possible in your setup.
// Enable / disable simulcast support.
     disableSimulcast: true,

Thank you for the support Freddie.
Q) Does the camera quality also matter? One thing that I have noticed if I use cell phone, the picture quality improves, as the cell phone has a better camera.

Has anybody solved this horrible video quality issue yet? I’ve been using jitsi for two years without ugly video until now. I built a new system using the latest build and the quality sucks.

I’ve tried changing constrained video parameters, frame sizes, everything I’ve seen in this forum… NOTHING changes the quality.

I’ve got full 1gb fiber conneciton up/down to transmit the presenters screen. As soon as somebody joins the meeting, the quality is reduced to 180p or less.

When screensharing our presenter screen with a 1gb connection, the quality still drops to 180p or lower…

This is clearly unacceptable… What can be done?

Have you checked your js console for errors, seems the websocket to the bridge is not working.

I’m very very very new at this stuff. I have no idea what a JS console is or how to check websockets. Most likely I haven’t checked it as a result. How do I do that?

In Chrome, go to the View menu, point to Developer, and choose Javascript Console. Look for red messages.

If the quality is as bad as you describe, on a good quality connection, something is not set up correctly.