Impossible to install jitsi-meet on my Debian dedicated server 9.6 (stretch)

I always get this message :
“Les paquets suivants contiennent des dépendances non satisfaites :
jitsi-meet : Dépend: jicofo (= 1.0-740-1) mais ne sera pas installé”

If I try previously to install jicofo I get :
“Les paquets suivants contiennent des dépendances non satisfaites :
jicofo : Dépend: ruby-hocon mais il n’est pas installable”

After searching for “ruby-hocon”, I have found that it is not listed in the available packages…

Do you have a solution?

Nope, nothing other than updating the system to a more up-to-date version.

Thank you for your answer Damencho,
but this dedicated server have a special OS modified by OVH France, so I cannot change the OS…

Is it possible to find that package elsewhere and install it manually?

Try if these work for you…

Thank you Prashanth,

the installation worked perfectly!

But I’m still not accessing the Jitsi meeting application…

I assigned a subdomain to one of my domain “”, it is validated in my DNS records, a let’s Encrypt certificate was assigned to it and I can ping it!

But still when I type it in my browser, I only view my main index page of my domain…

It seem that Apache2 did not reroute the connection to “/usr/share/jitsi-meet”.

[Edition] I was able to redirect manually the subdomain to “/usr/share/jitsi-meet”, but now I see only a blank gray page!

Anyone can help me?

Check the js console logs for errors.

This is what I see in my console :

(TIME) index.html loaded: 363

2021-05-07T20:48:10.774Z [modules/browser/BrowserCapabilities.js] This appears to be firefox, ver: 72.0 [Logger.js:154:22]

ReferenceError: config is not defined[AuthHandler.js:20:37]

It seem that the object “config” is not initialize somewhere in the process…

Probably a missing comma in your config.js file. If you made changes to that file, undo them or examine carefully for a missing comma (,)

Most probably your Apache has ssi turned off. Not sure how, but that needs to be enabled.

This is maybe, mod_include …

To Corby :
I have not touch the original config.js file!

This is a fresh installation…

I wonder why I still have lines like “domain: ‘’,” instead of my own domain name!

To Damencho:
you were right that SSI was not enabled for this domain, but even if SSI is enabled nothing change!

Since the server is a hosting server, SSI is enabled on specifics sites basis.

I wonder if I could add a .htaccess file in /usr/share/jitsi-meet to accomplish this locally?

If this is in /etc/jitsi that is strange …

But looking at your deployment address ssi is still not on. You should not see lines like jitsi-meet/index.html at 98078f9160bd1428dcec7293d75c3ea3fd2b9d15 · jitsi/jitsi-meet · GitHub in the source code of the page in the browser.

This line was inside the file “/usr/share/jitsi-meet-web-config/config.js”, like if it was not configured properly…

I agree with you that the SSI is not working for the application. I wonder why the developers did not used the proper way to include files with “.shtml” suffixes?

I tried to enable the SSI with an “htaccess” file in the “/usr/share/jitsi-meet” directory to no avail…

P.S. I just noticed that it is also “including” javascript files :
<script><!–#include virtual="/config.js" --></script>
<script><!–#include virtual="/interface_config.js" --></script>
<script><!–#include virtual="/logging_config.js" --></script>

I cannot see those files anywhere…

This is the template, it is used to create the correct one which is in /etc/jitsi/meet/…

This is in your apache config:

Those are in /usr/share/jitsi-meet/

Thank you very much for your help Damencho!

OK, I have found the config.js file properly configured at that place!

But I cannot understand why apache do not include the files inside the index.html file…

Those files properties are for “group:owner” root:root and permissions “rw-r–r–” (0644).

Is this right?

Not sure … maybe is ok … Check apache logs

There is nothing in the Apache log that seem to be an error…

It seem that SSI is not working for that specific directory, because it is working elsewhere…

I was finally able to grant SSI for that directory, now there is a last issue. The alias for the “config.js” file is not working as specified in the apache config file :

Alias “/config.js” “/etc/jitsi/meet/”
<Location /config.js>
Require all granted

The redirection is not working, if I copy the file in the root directory it is working as you can see on the website, but it is still impossible to create a meeting place…

@rej do you think it is a jitsi related issue? Or apache?