iframe#jitsiConferenceFrame0 steals focus

Hey out there! I need urgent help. I would be very thankful for helping solving my problem.
I am implementing a MVC Application for an online group experiment. In the experiment groups of three members must solve tasks together within a google docs (first iframe) communicating only via chat (jitsi meet API).
The problem is, that the jitsi chat always steals focus, so that typing into the google docs is not possible. Tried to set focus again and again on the google doc with kind of that code:

function setFocusThickboxIframe() {
    var iframe = $("#TB_iframeContent")[0];
    iframe.contentWindow.focus();
}
$(document).ready(function(){
   $("#id_cmd_open").click(function(){
      /*
         run thickbox code here to open lightbox,
         like tb_show("google this!", "http://www.google.com");
       */
      setTimeout(setFocusThickboxIframe, 100);
      return false;
   });
});

But that does not work. Jitsi focus is “stronger” - unfortunately. Any ideas?

Here a screenshot from the online experiment and debugging mode:

Jitsi API integrated as follows:

function registerCommunicationClient() {
            //doku: https://github.com/jitsi/jitsi-meet/blob/master/doc/api.md
            $.ajax({
                type: "GET",
                url: "/Experiment/get_CommunicationParameters",
                contentType: "application/json; charset=utf-8",
                dataType: "json",
                success: function (response) {
                    var domain = "meet.jit.si";
                    var options = {
                        roomName: response.communicationID,
                        width: 400,
                        parentNode: document.querySelector('#div_Communication_Container'),
                        height: 900,
                        configOverwrite: {
                            disableSuspendVideo: false
                        },
                        interfaceConfigOverwrite: {
                            filmStripOnly: false,
                            SHOW_JITSI_WATERMARK: false,
                            MAIN_TOOLBAR_BUTTONS: [],
                            TOOLBAR_BUTTONS: ['chat'],
                            INVITE_OPTIONS: []
                        }
                    }
                    if ((response.communicationChannel != 'FaceToFace') && (response.communicationChannel != 'Individual')) {
                        api = new JitsiMeetExternalAPI(domain, options);
                        api.executeCommand('displayName', response.nickname);
                        api.executeCommand('toggleFilmStrip');
                        if (response.communicationChannel == 'Audio') {
                            api.executeCommand('toggleVideo');
                        }
                        else if (response.communicationChannel == 'Chat') {
                            api.executeCommand('toggleVideo');
                            api.executeCommand('toggleAudio');
                            api.executeCommand('toggleChat');
                            api.executeCommand('muteEveryone');
                        }
                    }
                },
                failure: function (response) {
                    alert("Failure in Method registerCommunicationClient() in View Experiment");
                },
                error: function (response) {
                    alert("Error in Method registerCommunicationClient() in View Experiment");
                }
            });
        }

Sorry, I have no idea how to go about this…

Thanks for reading and thinking about my problem. I discovered more details of my problem, but not a solution yet:
The problem occurred after the new Jitsi Update (is probably related to this, but does not have to)
If I remove within the Debugging Mode in the Textare the Listener “blur”: Window, it works:

Thus I know where the problem is, but I can’t handle it within my code. Does anybody know how to remove this handler? I already tried.

Its a bit of a far-fetched guess but may be worth a try: Can you try to add DISABLE_VIDEO_BACKGROUND: true, to your interfaceConfigOverwrite?

Hi plokta, thank you for your guess. I tried it but unfortunately it does not work…

In hindsight, it was a dumb guess anyway, not taking into account that you are talking specifically about the onblur eventhandler.

You could try to use removeEventListener() on the usermsg element but you’d need to know the exact function definition for this to work. While you could of course extract the function from the minified script, it may change any time an update is deployed to meet.jit.si. So its likely a better idea to selfhost your own Jitsi instance using the stable version that you know to be working for your usecase.