I started videobridge (compiled from sources) and had HTTP ERROR 404

I downloaded sources of videobridge, compiled and started it.
When i try to open 127.0.0.1:8080 in my browser i had:

HTTP ERROR 404

Problem accessing /. Reason:
Not Found
Powered by Jetty:// 9.4.15.v20190215

Console:
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
2020-08-03 15:45:04.477 INFO: [12] ReadOnlyConfigurationService.reloadConfiguration#40: net.java.sip.communicator.SC_HOME_DIR_LOCATION not set
2020-08-03 15:45:04.540 INFO: [12] ConfigurationActivator.start#45: Registered the legacy ConfigurationService in OSGi.
2020-08-03 15:45:04.556 INFO: [12] AbstractVersionActivator.start#91: VersionService registered: JVB 2.1.SNAPSHOT
2020-08-03 15:45:04.695 INFO: [12] org.eclipse.jetty.util.log.Log.initialized: Logging initialized @1322ms to org.eclipse.jetty.util.log.JavaUtilLog
2020-08-03 15:45:04.932 INFO: [12] org.eclipse.jetty.server.Server.doStart: jetty-9.4.15.v20190215; built: 2019-02-15T16:53:49.381Z; git: eb70b240169fcf1abbd86af36482d1c49826fa0b; jvm 11.0.6+10-post-Ubuntu-1ubuntu118.04.1
2020-08-03 15:45:06.175 INFO: [12] org.eclipse.jetty.server.handler.ContextHandler.doStart: Started o.e.j.s.ServletContextHandler@6928cbd4{/,null,AVAILABLE}
2020-08-03 15:45:06.239 INFO: [12] org.eclipse.jetty.server.AbstractConnector.doStart: Started ServerConnector@9041860{HTTP/1.1,[http/1.1]}{0.0.0.0:8080}
2020-08-03 15:45:06.240 INFO: [12] org.eclipse.jetty.server.Server.doStart: Started @2867ms
2020-08-03 15:45:06.645 INFO: [12] AbstractJettyBundleActivator.start#628: Not starting the Jetty service for org.jitsi.videobridge.websocket.WebSocketBundleActivator(port=-1)
2020-08-03 15:45:06.702 WARNING: [12] UlimitCheck.printUlimits#111: Running with open files limit 1048576 (hard 1048576), thread limit 3854 (hard 3854). These values are too low and they will limit the number of participants that the bridge can serve simultaneously.
2020-08-03 15:45:06.723 INFO: [12] VideobridgeExpireThread.start#90: Starting with 60 second interval.
2020-08-03 15:45:07.063 INFO: [12] AbstractHealthCheckService.start#107: Started with interval=10000, timeout=PT30S, maxDuration=PT3S, stickyFailures=false.
2020-08-03 15:45:07.129 INFO: [12] OctoRelayService.start#45: Octo relay is disabled
2020-08-03 15:45:07.597 INFO: [24] org.ice4j.ice.harvest.MappingCandidateHarvesters.initialize: Initialized mapping harvesters (delay=541ms). stunDiscoveryFailed=false
2020-08-03 15:45:17.087 INFO: [25] TaskPools.#81: TaskPools detected 2 processors, creating the CPU pool with that many threads
2020-08-03 15:45:17.092 INFO: [25] Videobridge.createConference#257: create_conf, id=8952dbcdd8eafec3 gid=-1 logging=false
2020-08-03 15:45:17.378 INFO: [25] org.ice4j.ice.harvest.AbstractUdpListener.: Initialized AbstractUdpListener with address [2a00:f940:2:4:2:0:0:16a1]:10000/udp. Receive buffer size 212992 (asked for 10485760)
2020-08-03 15:45:17.379 INFO: [25] org.ice4j.ice.harvest.SinglePortUdpHarvester.: Initialized SinglePortUdpHarvester with address [2a00:f940:2:4:2:0:0:16a1]:10000/udp
2020-08-03 15:45:17.381 INFO: [25] org.ice4j.ice.harvest.AbstractUdpListener.: Initialized AbstractUdpListener with address 127.0.0.1:10000/udp. Receive buffer size 212992 (asked for 10485760)
2020-08-03 15:45:17.386 INFO: [25] org.ice4j.ice.harvest.SinglePortUdpHarvester.: Initialized SinglePortUdpHarvester with address 127.0.0.1:10000/udp
SCTP JNI load: Linux OS detected
SCTP lib loaded
=====>: org_jitsi_modified_sctp4j_SctpJni.c calling init
2020-08-03 15:45:18.780 INFO: [25] AbstractHealthCheckService.run#182: Performed a successful health check in PT1.721271S. Sticky failure: false
2020-08-03 15:45:27.061 INFO: [25] Videobridge.createConference#257: create_conf, id=37caa90cd94604d gid=-1 logging=false

is it not the normal answer with standard jvb ?
what gives

curl 127.0.0.1:8080/colibri/debug

{“shutdownInProgress”:false,“time”:1596523684379,“health”:“OK”,“e2e_packet_delay”:{“rtp”:{“average_delay_ms”:null,“max_delay_ms”:0,“total_count”:0,“buckets”:{"<= 2 ms":0,"<= 5 ms":0,"<= 20 ms":0,"<= 50 ms":0,"<= 200 ms":0,"<= 500 ms":0,"<= 1000 ms":0,"> 1000 ms":0,“p99<=”:-1,“p999<=”:-1}},“rtcp”:{“average_delay_ms”:null,“max_delay_ms”:0,“total_count”:0,“buckets”:{"<= 2 ms":0,"<= 5 ms":0,"<= 20 ms":0,"<= 50 ms":0,"<= 200 ms":0,"<= 500 ms":0,"<= 1000 ms":0,"> 1000 ms":0,“p99<=”:-1,“p999<=”:-1}}},“overall_bridge_jitter”:null,“conferences”:{}}

Everything works fine, congrats for a successful compilation :slight_smile:

Thank you, i was surprise by so long logs.

default log level is INFO, that’s a bit verbose indeed.
Correction: when I said that everything works fine, that means that Jvb starts and runs since the colibri interface is working. That does NOT mean that everything is running correctly, you have to test jitsi-meet a bit to say that.

1 Like

:crossed_fingers: