I hosted this jitsi-meet inside an aws ubuntu 18 instances but it s not accessable by me . any help

  1. i used the official github jitsi source code inside an ec2 instance of ubuntu 18.04.
  2. then open my all port like 8000,8080,80,all udp port and also 843 port .
  3. then i used official command provided by jitsi-official page. like
sudo apt-get install npm nodejs
cd jitsi-meet
npm install lib-jitsi-meet --force && make deploy-lib-jitsi-meet
make dev
  1. after that compiled successfuly message shown in ubuntu instance.

problem

  1. when i use public dns :8000 or 8080 or 8443 its not shown the landing page.
    kindly needed the guide steps for it.

any help.

Ports for 18.04 are
web 4444 and
turn 4445

all proxied when reaching 443
Why don’t you have 443 open?

Jitsi uses the https so i opened 443 as well.But after that my landing page also not shown in browser.

What are you trying to accomplish?
You don’t have to compile from source.

If you just want to run your own jitsi server, use the quick install guide.

Furthermore, if your server is running on AWS infrastructure, you need some AWS specific settings:

1 Like

@rajaprasad_paikaray
May I suggest you to use this script:

If you don’t want/need the jibri part since it will increase significantly the resources demand, you can just still install it and ignore the livestream and loca recording buttons.

Cheers!