I cant seem to get jitsi installed

i have tried to install jitsi many times on an ubuntu 18.04 server vm, running on unraid. i can seem to get to the letsencrypt install, but my domain name seems to fail.

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address.

Hi @Kris_Barrett - I’m new to Jitsi as well and had trouble installing last week, also on a new Ubuntu 18.04 server. But I got it going. So now, I guess I’m an expert :slight_smile: :

  • What procedure are you using to install? I used the Quick Install procedure, and now it runs OK.
  • You are right about DNS A and AAAA records, especially for let’s encrypt. You must have those records in your DNS server before you start the Quick Install process.
  • What do you see if you enter `hostname` command (with the backticks) on the command line? Does it contain the FQDN (fully qualified domain name) e.g. myhost.com or jitsi.myhost.com not just myhost?
  • Finally, what exact error message/indication do you see when letsencrypt fails?

Thanks.

I have tried a couple different procedures I have found. The quick install is one of them.

sing the webroot path /usr/share/jitsi-meet for all unmatched domains.
Waiting for verification…
Challenge failed for domain gatherddnsnet
http-01 challenge for gatherddnsnet
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

Traffic to /.well-known is going to the wrong place. Where are you directing it?

Host name is just gather

How do I find where it’s being directed?

Your web server config. The request is being directed to a page which responds with “Welcome to our server”.

Thanks for this additional information - it gives me a clue. The long URL (https://gather.ddns.net/.well-known/acme-challenge/TeWh4…) is a query from the Let’s Encrypt (LE) server to your Jitsi server to see if it has the right credentials to validate the LE certificate. But the LE server is reporting that it can’t reach/connect to the Jitsi server you’ve set up. (It’s reaching some server, but not the one you want.)

I suspect you are trying to set up Jitsi on a server at your home or office, since you’re using no-ip.com/ddns.net to publicize an IP address for your location. (Jitsi requires a public IP address/domain name. You probably don’t have a fixed address from your ISP.)

If this is correct, one problem could be that your router is providing NAT (“Network Address Translation”). If this is the case, you may have to add the Jitsi server to your “DMZ” (De-militarized zone - yes, that’s the technical term) so that traffic destined for Jitsi from the “outside” will be passed through the router to the Jitsi computer on the “inside” of your network.

Sorry I cannot be more specific - the setup of a DMZ depends on the kind of router you’re using. (Or I may be totally off-base… Let me know. Thanks.)

Let’s Encrypt is reporting that it is getting a response from a web server, just not the response it is expecting. But something is answering its request.

That could be the machine running jitsi, but the web server is misconfigured but, yes, as you say, it could also be a different machine’s web server answering it.

Oh wait. I just re-read this response… I’m not sure this is total answer, but it could make a big difference:

Be sure to edit /etc/hostname and /etc/hosts as indicated in the Quick Install. Make sure /etc/hostname has the FQDN - gather.ddns.net, and that name appears in the /etc/hosts as indicated.

Update: The easiest way to apply changes to /etc/hostname and /etc/hosts is to reboot the server, then re-run the Quick Install process.

I have the hostname as gather.ddns.net now, after reboot. Still getting the same issues.
Im actually at work right now, so changing my router isnt easy to do on my phone, lol.

Is there a way to tell where my domain is directing to? That would make sense, if i turn the jitsi server off, it doesnt change where my domain takes you.

Ok, im using an edgrouter x, looks like i setup destination nat to act like a dmz. I set it up like i found online, not sure if its correct or not. Still getting same thing when i try to access the domain

Thank you both for trying to help me

U nano 2.9.3 /etc/hosts

127.0.0.1 localhost gatherddnsnet
24.127.198.226 gatherddnsnet

The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

This is my hosts file. Not sure this is correct. Also when i try to access the ip of the server, i get rediected to a welcome to nginx

I’m guessing it has dots in the right places in the real thing?

When i try to access the ip of the server, i get rediected to a welcome to nginx

@Kris_Barrett I see a couple potential problems in /etc/hosts…

  • gather.ddn.net should have “.” in the proper place
  • I don’t think you need to have the second line (with the 24.127… address) - try commenting it out.

And a tip to make it easier to read pasted output: This forum supports Markdown formatting, so you can put text in a monospace font: either put it between back ticks (`) in one line, or between two lines that only have three back-ticks (```) Thanks.

Yeah, i have dots in the correct areas, wouldnt let me post with them. @richb-hanover posting properly here might have let me copy and paste properly

Yes. the forum makes it hard for you to post (bad, spammy, evil) addresses.

Well… it probably is some settings in my router. I setup dynamic dns in the router. But after that my gateway address took me to my jitsi server. So, jitsi does work on the server. But I couldnt connect to the internet because 192.168.1.1 was now jitsi server. So after getting into my unms docker, I was able to cli to delete the dynamic dns, ssh didnt work.

ok i did find out that the ddns is directing to my router, an edgerouter. not i will just have to figure out what is needed to pass it along.

That makes sense — you’re probably looking for config for NAT, to pass traffic to TCP ports 80, 443, and UDP 10000 to your jitsi server.