I can't overwrite the toolbar buttons from since it was moved to config.js

Hi!
since toolbarbuttons is modified with configoverwrite I cannot modify the buttons. An example with this code:

const domain = “meet.jit.si”;
const options = {
configOverwrite: {
toolbarButtons: [‘microphone’, ‘closedcaptions’, ‘embedmeeting’, ‘fullscreen’, ‘fodeviceselection’, ‘profile’, ‘chat’, ‘recording’, ‘livestreaming’, ‘etherpad’, ‘sharedvideo’, ‘settings’, ‘raisehand’, ‘videoquality’, ‘filmstrip’, ‘feedback’, ‘stats’, ‘shortcuts’, ‘tileview’, ‘select-background’, ‘download’, ‘help’, ‘mute-everyone’, ‘mute-video-everyone’],
prejoinPageEnabled: false,
channelLastN: 4,
startWithAudioMuted: true,
startWithVideoMuted: true,
},
roomName: “prueba.1.prueba”,
interfaceConfigOverwrite: {
SHOW_JITSI_WATERMARK: true,
JITSI_WATERMARK_LINK: ‘https://jitsi.org’,
},
width: ‘100%’,
height: 650,
}
const api = new JitsiMeetExternalAPI(domain, options);

The buttons share desktop and cam should not appear but it’s appearing


When I did it with interfaceConfigOverwrite I had no problem. Anybody know what could be happening?

Thanks!!! :slight_smile:

If you are doing it on meet.jit.si you need to do it “the old way” since we have some backwards compatibility code which is used when the option is present in interface_config. You can set it in both to be sure.

Thanks! you are right, although it’s deprecated in interface_config.js, it is still overwritten with interfaceConfigOverwrite

And how do I disable those buttons if I have a local installation?

Changing the toolbarButtons in /usr/share/jitsi-meet-web-config/config.js does not seem to work?

PS: To me it seems, /usr/share/jitsi-meet/interface_config.js is still the only file that is being read?

If you have the old config in interface config it will take precedence over the new one. Is this your case perhaps?

I had the toolbarButtons Section disabled in interface_config.js. So it should not have taken precedence? Will retry tonight, perhaps it was a caching issue for the js files.

It’s TOOLBAR_BUTTONS in interface_config.

Jep.

    //TOOLBAR_BUTTONS: [
    //    'microphone', 'camera', 'closedcaptions', 'desktop', 'embedmeeting', 'fullscreen',
    //    'fodeviceselection', 'hangup', 'profile', 'chat', /*'recording',*/
    //    /*'livestreaming', 'etherpad', */'sharedvideo', 'shareaudio', 'settings', 'raisehand',
    //    'videoquality', 'filmstrip', 'invite', 'feedback', 'stats', 'shortcuts',
    //    'tileview', 'select-background', 'download', 'help', 'mute-everyone', 'mute-video-everyone', 'security'
    //],

I have also tried to disable E2EE, because users keep playing with it and kill the channel. But it’s still displayed even with this setting:

        // Disables the End to End Encryption feature. Useful for debugging
        // issues related to insertable streams.
        disableE2EE: true,

By the way, what are fodevices? :slight_smile:

Oh, looks like when we refactored things around we no longer honor disableE2EE. Can you open an issue on GH?

Funny enough nothing, anymore. We should get rid of that entry there.

2 Likes

Thanks!