I am not able to get shibboleth metadata

Hi,
I am new to jitsi server. I have the following query
1.After installation I am not able to speak and I am not able to unmute and video is not working.
Others are not able to see my video and can’t hear me , the same is for me too, I am not able to see and hear others video and audio.
2. I have installed shibboleth on the server and it’s not opening the metadata
e.g. https://xxx/Shibboleth.sso/Metadata is always creating one new meeting
not actual metadata.
As I want to register my sp metadata into IDP , I am not able to open the above said page.
3. I stopped all the below mentioned service
sudo /etc/init.d/prosody stop
sudo /etc/init.d/jicofo stop
sudo /etc/init.d/jitsi-videobridge stop

Then also I am getting the jisi meet page

Please guide me how to make my conference work with good quality of video and audio at the same time with shibboleth authentication.
This is my first project to set it up and it is very urgent also.

Please do the needful

Regards,
Malathi

Hi Malathi,
Hi all,

i have the same problem as you. I’m not able to get the Metadata File from the https://xxx/Shibboleth.sso/Metadata Adress. Can someone provide help or hints to solve the problems, please?

Kind regards
Jan

Hi Malathi,

got it working. In the jicofo/shibboleth.md at master · jitsi/jicofo · GitHub the location settings seem to miss something before the path:

location ^~ /shibauthorizer {
  internal;
  include fastcgi_params;
  fastcgi_pass unix:/opt/shibboleth/shibauthorizer.sock;
}

location ^~ /Shibboleth.sso {
  include fastcgi_params;
  fastcgi_pass unix:/opt/shibboleth/shibresponder.sock;
}

location **^~** /shibboleth-sp {
  alias /usr/share/shibboleth/;
}

location ^~ /login {
  more_clear_input_headers 'Variable-*' 'Shib-*' 'Remote-User' 'REMOTE_USER' 'Auth-
Type' 'AUTH_TYPE';
  more_clear_input_headers 'displayName' 'mail' 'persistent-id';
  shib_request /shibauthorizer;
  proxy_pass http://127.0.0.1:8888;
}

Details:
location = / - will only match the root path
location ^~ /community - will match every path starting with /community
location ~ .pl - will match all files that contain .pl
location ^~ /news - will match every path starting with /news
location ^~ /app - will match every path starting with /app
location / - will match all paths not matched above

Maybe it helps you.

Kind regards
Jan

Since we are at it… if you get the error “mail” not provided after you are autheticated through the idp…

add this line in the nginx config (in the Location ^~ /login)
shib_request_use_headers on;