Https not working on quick install

Good morning,
I’m having some problems installing jitsi (last release), after uninstalling a previous version.
The commands I executed were:
sudo apt-get --purge remove jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config jicofo jitsi-videobridge jitsi-videobridge2 prosody
sudo apt-get autoremove
sudo apt-get -y install jitsi-meet
The certificates are autogenerated.
The quick install process works fine (no errors).
But after that I cannot access the home page: my browser gives me “ERR_CONNECTION_CLOSED” when trying to access in https.
Status of Jicofo, Prosody and Videobridge2 are ok.
I can only access the http page (the nginx welcome).
Any ideas?

Pleasy post you ngix configuration and its log file

this is the result of systemctl status nginx:
● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2020-04-01 13:00:30 UTC; 18s ago
Docs: man:nginx(8)
Process: 14858 ExecStop=/sbin/start-stop-daemon --quiet --stop --retry QUIT/5 --pidfile /run/nginx.pid (code=exited, status=0/SUCCESS)
Process: 16888 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=1/FAILURE)
Process: 16875 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
Main PID: 11219 (code=exited, status=0/SUCCESS)

Apr 01 13:00:28 videoconf2 systemd[1]: Starting A high performance web server and a reverse proxy server…
Apr 01 13:00:28 videoconf2 nginx[16888]: nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
Apr 01 13:00:28 videoconf2 nginx[16888]: nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
Apr 01 13:00:29 videoconf2 nginx[16888]: nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
Apr 01 13:00:29 videoconf2 nginx[16888]: nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
Apr 01 13:00:30 videoconf2 nginx[16888]: nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
Apr 01 13:00:30 videoconf2 nginx[16888]: nginx: [emerg] still could not bind()
Apr 01 13:00:30 videoconf2 systemd[1]: nginx.service: Control process exited, code=exited status=1
Apr 01 13:00:30 videoconf2 systemd[1]: nginx.service: Failed with result ‘exit-code’.
Apr 01 13:00:30 videoconf2 systemd[1]: Failed to start A high performance web server and a reverse proxy server.

I find that turnserver is listening on port 443. I have not installed other web servers.

I have a similar issue, as port 443 in the NGINX modules config interferes with my existing configuration for my other site config (which is also listening on 443 with a dedicated hostname).
I tried to summarise it in a GitHub issue https://github.com/jitsi/jitsi-meet/issues/5528
A similar threat is here: Nginx, coturn & port 443
and here Is there a way to revert to Jitsi before 30-03-2020?

This was exactly my case: https://github.com/jitsi/jitsi-meet/issues/5528. Thank you @HachimanSec and @m4tteo.

1 Like