Http-bind return 502 when token_verification module enabled

I installed jitsi from here: https://jitsi.org/downloads/
And everything worked well until the jwt token was activated.
I solved most of the problems by reading:
https://github.com/jitsi/jitsi-meet/issues/4406
https://fatiherikci.com/en/install-jitsi-meet-on-debian-10/
Jwt authentication bug
Restricting room creation only to token-authenticated users
JWT token authentication broken on debian 10 with openssl 1.1
Error during jitsi-meet-tokens installation
https://github.com/jitsi/jitsi-meet/issues/2029

Now, when I uncomment the “token_verification” in the prosody configuration, I get 502 at jitsimysite.com/http-bind


Debian 4.19.67-2+deb10u1

prosodyctl about
Prosody 0.11.2
Lua version: Lua 5.2
LuaRocks: Installed (2.4.2)


VirtualHost “jitsimysite.com
authentication = “token”
app_id=“xxxxx”
app_secret=“sssss”
c2s_require_encryption = false

Component “conference.jitsimysite.com” “muc”
storage = “memory”
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
– uncommented
“token_verification”;
}

I do not see any errors in logs prosody.
The only thing I skiped was the prosody-trunk installation

dpkg -i prosody-trunk_1nightly747-1 ~ trusty_amd64.deb

from https://github.com/jitsi/lib-jitsi-meet/blob/master/doc/tokens.md#patching-prosody
Do I really have to do this?
if so, which version? (Https://packages.prosody.im/debian/pool/main/p/prosody-trunk/)

Prosody 11 is fine. check prosody for errors.

I have no errors in prodyody logs.
Only in nginx can I see:

failed (111: Connection refused) while connecting to upstream, client: 127.0.0.1, server: jitsimysite.com, request: “GET /http-bind HTTP/2.0”, upstream: “http://[::1]:5280/http-bind”, host: “jitsimysite.com

but this error only occurs:

authentication = “token”

when i set:

authentication = “internal_line”

everything is fine

When you set authentication = “token” and restart prosody, do you have errors or warnings?