How to use my own jitsi server for both web and mobile app?

Hi,
I follow the steps in this link to run the jitsi-meet web application :


and it works succussfully
also i follow this link to run the jitsi-meet mobile app:

and it works succussfully on device .

Now i want to change the default server domain in order to use my own jitsi server for both web and mobile app ,
I try changing the domain in the projects file config.js but it doesn’t work?

So how can i change to my own server ?any idea please ? thanks

You can use even the play/app store version with your server. There is a setting for that. Or you can just type the whole URL https://example.com/roomname for room, this will also work.

1 Like

First, thanks for the reply

i wanna know if i can change the server :" meet.jit.si" in jitsi-meet git repository to my own server ?
if yes , what are the steps should i follow
Thanks

Yes you can, search in the code for that string.
Build the mobile app, read the docs that are provided for the OS you want to build it for.

HI

i follow this tutorial to build out install jitsi:
https://github.com/jitsi/jitsi-meet/issues/2531

it works succussfuly but the webcam and audio doesn’t work . it gives me the following errors in the console:

Uncaught (in promise) TypeError: e.isReceivingData is not a function
at app.bundle.min.js?v=139:60

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: TypeError: e.isReceivingData is not a function
at app.bundle.min.js?v=139:60

THANKS

The recommended tutorial for deploying is http://jitsi.org/qi

What could be the reason my own server/url doesn’t work with the iPhone app changing the base url from the settings nor passing the full https url from the meeting room input.

The server is ser with the secure layer explained in the repo, in case could be useful to understand the reasons. Also works as expected using the Android App.
Thanks in advance,

I get same error on Android. Passing full url does not work and same with setting server base url. Keep showing the prompt that “You have been disconnected and asking to rejoin.” Actually it never established the connection with server.

Sounds like you need to open ports. 80 443 10000

Same issue for me too …
Didi you find why ?

I ran into this issue today. Turns out you need a valid SSL cert to have the android/ios client use your server

1 Like

thanks…can you please share details steps. configured on sever and updated hostname in activity page. however what else we need it would be great help if you can share the details. will follow them

thanks in advance

Not sure if this will be much help, but I followed the steps here:

Specifically, it was this command to get the cert going:
/usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

I followed exactly these steps: .
and it worked out well for me

  • Create Instacia EC2
  • Generate an Elastic IP
  • Add DNS to your domain.
  • When you generate the certificate, you add the domain to it.

Sorry about my English.

Hi All,

If i check jitsi meet documentation for developer, i don’t see any installation step for mobile/react native in this doc Developer Guide (Mobile) · Jitsi Meet Handbook. Is it miss? or for mobile/react native, it has new documentation path/domain? please answer

@rusli_Abdul_gani Welcome to the forum.

The information is right there on the page you linked. You’ll need some familiarity with react native, installing the necessary dependencies e.t.c… But the info that you need to compile the mobile app is there in the Developer Guide.

yeah i see there are some step, but it’s step for react native itself instal and init project… where is step for such like “npm install save jitsi-meet” or “yarn add jitsi-meet” or i don’t know the step for jitsi meet react native itself no one step occur in there. or you can explain how to do it (react native jitsi meet installation)?

example for IOS:
i see there “pod install” but what pod already add there? jitsi meet? why it’s directly to pod install? before pod install you need to install package first right? such as sample “npm install jitsi-meet” or something. i don’t see there.

why first step is npm install? is there any existing repo? how can i do jitsi meet for react native but i want to develop RN project by myself and i just wanna add jitsi meet in my project? is it possible??