How to support 1080p?

meet
#1

I customed setting manage call quality,
image

when the second participant enters the meeting room, the issue fellow:
image

what should I do?

0 Likes

#2

What changes did you make specifically?

0 Likes

#3
  1. I changed react/features/base/conference/constants.js:
export const VIDEO_QUALITY_LEVELS = {
    SUPER: 1920,
    HIGH: 1080,
    STANDARD: 360,
    LOW: 180
};

I added ‘SUPER: 1920,’.

  1. I changed react/features/video-quality/components/VideoQualitySlider.web.js:
const {
    SUPER,//add
    HIGH,
    STANDARD,
    LOW
} = VIDEO_QUALITY_LEVELS;
  1. I changed same file in constructor function ,added:

  2. I defined _enableSuperDefinition function:

_enableSuperDefinition() {
        sendAnalytics(createEvent('super'));
        logger.log('Video quality: super high enabled');
        this._setPreferredVideoQuality(SUPER);
    }
0 Likes

#4

That won’t work. The server only unserstands 3 quality levels. You can modify the config.js file for your deployment and set your preferred video constraints: https://github.com/jitsi/jitsi-meet/blob/26c9ee5f9cfcd009760c9a47ab3d0281454f0587/config.js#L103

0 Likes

#5

It works!
Thanks very much.

0 Likes