How to share playing music in a jitsi video group?

Hello, I’ve just recently joined Jitsi with this Covid-19… i usually run groups in person from babes and toddlers with their grownups, and now like everyone else i’m doing it online.

I can’t workout how to play music through my computer with Jitsi. Today I ran a session and just had my portable speaker next to the computer. I have usedZoom, so know about sharing music through that. Does anybody know if I can do that with Jitsi?

Thank you in advance,


1 Like

Soon this will be possible by sharing a tab with audio or on windows you will be able to share an app with audio.


Any idea when? And am I right from your answer in figuring that I definitely can’t do this yet?


Yes, probably next week when we do another update on …


In the interim, you probably need some software which redirects the output of your music program to a virtual mic, which you can then enable in Jitsi.

For macOS, there used to be something called SoundFlower.

1 Like

It’s great to hear that you’re about to implement audio sharing cause I have the same problem as Bela and audio sharing is a must-have feature. At this point, only Zoom supports it on mac through their Zoom Audio Device driver.

In your implementation, does that mean that all music must be played from a browser tab in mac OS or will we also be able to use eg the Spotify app or any other audio player? I have looked into creating a HAL plugin for mac for this issue (cause Soundflower is just too old and not user-friendly and Loopback is 120 USD), but it seems like a huge project. This would be a great help.

1 Like

For Macosx that is possible only through another tab in the browser, on Windows you will be able to share an App and its audio, these is browser restrictions.

Thanks for your answer @damencho.

I wonder if there are any plans to integrate ‘share computer audio’ feature on mac os in the Electron or other Jitsi apps? Or do you happen to have any idea how we could solve this issue as it’s elemental for dance classes and any kind of music sharing online.

That is up to the browsers to implement it.

Yeah unfortunately, that’s not something we can wait for and Zoom has found a solution. If there’s anyone out there who has ideas, tipps, suggestions and/or ressources, I’d be very thankful.

Cannot wait to experience the new audio feature. This will be a game-changer add-on for my video-calls.
Thanks for the amazing and great work you do at Jitsi @damencho !!
I love your app. SOOOOO much better than any other on the market (zoom & co).

In the mean time I found Blackhole as free alternative to Loopback.
Not tested yet… Let’s see.

1 Like

Can confirm, although for Linux, that with JACK (something like ASIO for Windows) it’s easily possible to route sound i.e. from Spotify in a Jitsi-Meeting.

1 Like

Thanks @IceBear77 for the tip with Blackhole! It’s a lot more complicated to set up but did work in my tests - so that’s fantastic and means I don’t have to write one from scratch :tada:

Problem will JACK is that it’s just not user friendly. I cannot tell anyone to install it and ‘it works’. So great that there’s at least Blackhole for now.

And indeed, thanks @damencho for the work you do at Jitsi and the support community here.

1 Like

Wish me luck. I’m not super techie but i’m gonna head into the Black Hole… sounds like it’s the best for now. Thank you for everyone’s comments and help :slight_smile: :smiley:

Hi. Is it already implemented? I have tried (Chrome/Mac) with no luck. I don’t know if I’m doing something wrong or if it is not ready yet. Thanks!


Black Hole for macOS might do the trick, making your browser think that the audio output you set is a microphone / source.

Cool. Thanks!

út 7. 4. 2020 v 11:05 odesílatel Neil via Jitsi Community Forum - developers & users napsal:

Any pointer on some details on how to achieve that @legrex ? I am running Ubuntu and have QjackCtl installed.

Sorry, i was busy for the last couple of days.
Actually it is not even necessary to use JACK. Speaking for Linux you just need to change the Input-Setting for i.e. your running Chromium, to “Monitor of Internal Analogue Audio” instead of “Internel Analogue Audio”.
So if you are running Spotify, the Output of this is mixed to this Monitor-Signal and since you are setting your Input-Device of Jitsi (== Browser) to this Monitor, that’s it.

Guess with Windows it’s similar, because i remember Sound-Settings like “What you hear” there.