How to Remove Jitsi name/logo from iFrame API?

How to Remove Jitsi name/logo from iFrame API ?
Is there a way to remove the Jitsi logo from here:

jitsi1

I tried this without success:

const options = {

interfaceConfigOverwrite: {DEFAULT_LOGO_URL: 'images/watermark.svg', DEFAULT_WELCOME_PAGE_LOGO_URL: 'images/watermark.svg', SHOW_JITSI_WATERMARK: false },

configOverwrite: { logoImageUrl: 'https://example.com/logo-img.png'},

}

Also, how to remove jitsi logo from the video screen?
I look forward to any assistance, thanks

Are you hosting your own server or using the free instance at meet.jit.si? If you’re using the free instance, you’re not allowed to do that. Please review the TOS carefully.

Hi.
I’m hosting my own server, i followed this guide:

then I create the room with this properties:
const domain = ‘mydomain.co.uk’;
const options = {
roomName: myroom,
width: 600,
height: 480,
parentNode: document.querySelector(’#chatwindow’),
noSsl: false,
interfaceConfigOverwrite: {
DEFAULT_LOGO_URL: ‘/gfx/mylogo.svg’,
SHOW_JITSI_WATERMARK: false,
HIDE_INVITE_MORE_HEADER: true,
HIDE_DEEP_LINKING_LOGO: true,
DISABLE_JOIN_LEAVE_NOTIFICATIONS: true,
DISABLE_DOMINANT_SPEAKER_INDICATOR: true,
DISABLE_FOCUS_INDICATOR: true,
DEFAULT_BACKGROUND: ‘#474747’,
DEFAULT_WELCOME_PAGE_LOGO_URL: ‘/gfx/mylogo.svg’,
SHOW_JITSI_WATERMARK: true,
TOOLBAR_BUTTONS: [‘microphone’, ‘camera’, ‘hangup’, ‘mute-everyone’]
},
userInfo: {
displayName: ‘John Doe’
}
};
const api = new JitsiMeetExternalAPI(domain, options);

The videocall works fine, but the Jitsi logo is still appearing… as I read as im hosting it, i should be able to hide or replace the logo, am I wrong?

For those changes, you need to edit interface_config on your deployment.

1 Like

Perfect, I didn’t realise that. Now is working! Thanks!

@damencho @Juanma_Munoz So what were the steps you took? I have it installed my own server via Debian pkg , I can modify /etc/jitsi/meet/[your-hostname]-config.js, but there’s no /etc/jitsi/meet/[your-hostname]-interface_config.js. Do I have to make a new deb package just for this change?

The interface config is in /usr/share/jitsi-meet.

That worked, thanks.