How to register Jibri SIP account/ Invite Contact successfully in SIP server as no registration request is sent from

Hi. hope you are all fine.
We were trying to incorporate Jibri video Sip gateway in Jitsi. This installer instruction has been followed to install Jitsi Video-SIP-Gateway Installer. jitsi-videosipgw-installer
Also, following this listed document for step by step procedures. jibri as sip.

Our people search URL has been added and getting these from get-dail-plan.json.

But after inviting someone e.g: 7007 from the list there is no Register or Invite request coming to SIP server. In log I am getting Jibri is lunching but no indication of SIP call.

Selenium joined the call, starting pjsua
2023-02-28 10:07:59.615 INFO: [58] JibriSubprocess.launch#42: Starting pjsua with command /opt/jitsi/jibri/ --id=7007 <sip:jibri@> sip:7007@[/opt/jitsi/jibri/, --id=7007 <sip:jibri@>, sip:7007@])
2023-02-28 10:08:00.049 INFO: [61] StatefulJibriService.onServiceStateChange#39: SIP gateway service transitioning from state Starting up to Running
2023-02-28 10:08:00.050 INFO: [61] XmppApi$createServiceStatusHandler$1.invoke#334: Current service started up successfully, sending on iq <iq xmlns='jabber:client' to='' id='9NUHB-8' type='set'><jibri xmlns='' status='on' sipaddress='7007@'/></iq>
2023-02-28 10:08:04.623 FINE: [20] ProcessStatePublisher$startProcessAliveChecks$1.invoke#86: Process pjsua hasn't written in 2 seconds, publishing periodic update
2023-02-28 10:08:04.631 INFO: [61] StatefulJibriService.onServiceStateChange#39: SIP gateway service transitioning from state Running to Error: PjsuaExitedPrematurely SESSION Pjsua exited with code 1

If I manually run from terminal of my VM the sip account is getting registered in SIP server. So, I think my Jibri.config or pjsua.config is not correct. I am attaching this config.

pjsua.conf.txt (544 Bytes)
jibri.conf.txt (2.8 KB)

And this is :

usr/bin/sudo -E /usr/local/bin/pjsua --config-file /etc/jitsi/jibri/pjsua.config --id="sip:{{ inventory_hostname_short }}@{{ inventory_hostname }}" --auto-answer-timer=60  --auto-answer=200 > /dev/null

Any help would be appreciated. :slight_smile:

Did you install it using jitsi-videosipgw-installer or install it manually by simulating the installer codes?

hi @emrah. yes installed by jitsi-videosipgw-installer and then configured the pjsua.conf file.

actually I have not understood what is people search URL , I have a json file listing some users in there, but are those users registered in my SIP server? If I change asterisk SIP.conf with different users, then get-dial-plan.json file also need to change?

get-dial-plan.json contains the list of SIP clients who can be called by Jitsi. This SIP client should be registired in your SIP server when Jitsi calls them.

Ok, yes my current setup has those numbers and registered in SIP servers. but after I Invite one of them from meeting Drop down, no call or INVITE is sent to SIP server from Jibri.
Jibri is calling though as that can be found in Jibri log.

Normally it should work like this.

Can you check /var/log/jitsi/jibri/pjsua.log

@emrah thank you for the follow-up. We are trying this for several weeks now, really appreciating your help.
I am sharing pjsua.log.
pjsua_all.log (59.7 KB)
What I am understanding, Jibri is registering it’s SIP account in this case, 7008 but not calling INVITE to destination. Can you please check this if there is anything described?

pjsua cannot open the audio devices.

Thank you. let us check.



has solved this issue, now call is initiating, and my SIP device is connected and I can receive SIP device end’s video inside jitsi meeting, but meeting video is not received in SIP client end.

I’ve set --vcapture-dev=/dev/video0 as this and also tried with value=1, but occurring same.

Do you have audio when you do this?

Do you see the Jitsi Interface without the participant video in SIP client?

No, audio is not there.
and in sip client its showing local video in place of remote.

My list of playback device in vm are these:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Loopback [Loopback], device 0: Loopback PCM [Loopback PCM]
  Subdevices: 6/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7

This means that the video device ID is not correct in your config. Actually it works by default value, no need to update it.

There should be 2 video devices in /dev

Yes, you are right, there are two.
default was set as --vcapture-dev=0, does this indication first index of video device?

pjsua uses the first video device for capturing by default

hi @emrah . These are my ALSA device list, can you point out which index should I use for capture and playback-dev?

 alsa_dev.c  ..Added sound device samplerate
11:14:46.322             alsa_dev.c  ..Added sound device speexrate
11:14:46.330             alsa_dev.c  ..Added sound device jack
11:14:46.330             alsa_dev.c  ..Added sound device oss
11:14:46.331             alsa_dev.c  ..Added sound device pulse
11:14:46.331             alsa_dev.c  ..Added sound device upmix
11:14:46.331             alsa_dev.c  ..Added sound device vdownmix
11:14:46.332             alsa_dev.c  ..Added sound device amix
11:14:46.332             alsa_dev.c  ..Added sound device asnoop
11:14:46.332             alsa_dev.c  ..Added sound device aduplex
11:14:46.333             alsa_dev.c  ..Added sound device bmix
11:14:46.333             alsa_dev.c  ..Added sound device bsnoop
11:14:46.333             alsa_dev.c  ..Added sound device bduplex
11:14:46.334             alsa_dev.c  ..Added sound device pjsua
11:14:46.334             alsa_dev.c  ..Added sound device pjcap
11:14:46.334             alsa_dev.c  ..Added sound device pjply
11:14:46.334             alsa_dev.c  ..Added sound device default
11:14:46.336             alsa_dev.c  ..Added sound device sysdefault:CARD=Loopback
11:14:46.337             alsa_dev.c  ..Added sound device front:CARD=Loopback,DEV=0
11:14:46.337             alsa_dev.c  ..Added sound device dmix:CARD=Loopback,DEV=0
11:14:46.338             alsa_dev.c  ..Added sound device dmix:CARD=Loopback,DEV=1
11:14:46.339             alsa_dev.c  ..Added sound device dsnoop:CARD=Loopback,DEV=0
11:14:46.340             alsa_dev.c  ..Added sound device dsnoop:CARD=Loopback,DEV=1
11:14:46.340             alsa_dev.c  ..Added sound device hw:CARD=Loopback,DEV=0
11:14:46.340             alsa_dev.c  ..Added sound device hw:CARD=Loopback,DEV=1
11:14:46.340             alsa_dev.c  ..Added sound device plughw:CARD=Loopback,DEV=0
11:14:46.340             alsa_dev.c  ..Added sound device plughw:CARD=Loopback,DEV=1
11:14:46.340             alsa_dev.c  ..Added sound device usbstream:CARD=Loopback
11:14:46.341             alsa_dev.c  ..ALSA driver found 28 devices

Do I need plughw for 2 Loopback like Loopback,Loopback_1?

You need at least 2 loopback devices.

Why do you have pulse, jack, etc…? Is this a desktop machine?

It’s a vm (Linux os).

i have run this command: cat /proc/asound/cards
This printed

0 [Loopback       ]: Loopback - Loopback
                      Loopback 1