How to make the video filmstrip start hidden instead of visible

Hey Everyone,

Was trying to figure out how to start the filmstrip hidden by default.

Thanks for the help!

I don’t see an elegant way to do so right now without changing the codebase. The filmstrip starts as visible by default: https://github.com/jitsi/jitsi-meet/blob/cb3419ba2a899845c4ae58baf00100db10503aee/react/features/filmstrip/reducer.js#L26 and there’s no hook during application bootstrap to make it hidden.

If you’re looking for a code change, I’d probably start by adding something to interfaceConfg: https://github.com/jitsi/jitsi-meet/blob/cb3419ba2a899845c4ae58baf00100db10503aee/interface_config.js. Not sure where I’d use the value provided by interfaceConfig or its overrides… Maybe something in UI.js to begin with that checks the interfaceConfig and hides the filmstrip: https://github.com/jitsi/jitsi-meet/blob/cb3419ba2a899845c4ae58baf00100db10503aee/modules/UI/UI.js#L206.

Edit (had some more ideas):

  • If you can change the code you could try setting that value in reducer.js to false, so that the filmstrip is not visible by default.
  • If you’re using the iframe api you could cover the iframe, toggle the filmstrip, and then uncover the iframe.

Thanks a lot for the response, i will try some and let you know if anything works.

Edit: nothing seems to be working. Thanks again for your suggestions