How to make a single moderator


#1

Good day and thanks for the free tool Jitsi!

I apologize in advance if I repeat the question, but among the answers I have not found a solution to my problem.

Our situation is as follows: we have our own installation of the entire system Jitsi and it is configured to connect to the rooms through JWT

I see that everyone who connects to rooms through web tokens receive the role of moderator, which is unacceptable for us now. Thus it turns out that everyone can mute everyone. I suspect that the functions to mute and kick out of the room are only available to the moderator, right?

Thus, now the main question is how to make sure that having the authentication system through JWT the moderator is only the first one entering the room, and everyone else after it does not have this role?

I would be grateful for the indication of any way, how this can be implemented !!!

Thanks!


#2

Have you enabled this mod_muc_allowners?


#3

on the server in our installation jitsi-meet (/usr/share/jitsi-meet) there is a directory prosody-plugins and in it a file mod_muc_allowners.lua. But in the configuration of prosody (/etc/prosody/conf.d/domain.de.cfg.lua) to our virtual host it is not connected. With its connection, unfortunately, nothing changes :frowning:


#4

What about the global prosody config?
That is strange, so owners(moderator) is done by jicofo for the first one, or by this module for all. So not sure how this is possible, if it is not just a bug where ui shows it as moderator but basically it is not …


#5

There is no mention of muc_allowners, however, when trying to turn it on or off (modules_enabled or modules_disabled), it also has no effect…

Everyone who connects through JWT via Jitsi Meet API gets the right moderator


#6

Ok, so you have this enabled right enableUserRolesBasedOnToken ?


#7

I found this property (this - /etc/jitsi/meet/domain-config.js) and turned it on (true), but nothing has changed again. Every time I restart all services and try again.

maybe there is some opportunity to transfer a role to the context of a token? Moderator, guest?

or maybe i can pass something like https://domain_jitsi.com?jwt=someKindOfToken&role=anonymous


#8

I even completely removed the file /usr/share/jitsi-meet/prosody-plugins/mod_muc_allowners.lua and still all who enter the room are moderators :slight_smile: how can this be?


#9

@Roman_Zharikov: I have same problem and I want to create one Presenter and then only presenter have all rights not all joined users.

Suppose “A” started the class then “A” will be presenter and all who is joining this class “B”, “C”, “D” all must follow to “A”, only A can control to all.

Please help me if you have any solution for this.


#10

I Want to add to this, can we fix that the a particular user will be the moderator irrespective of who joins first ??


#11

@bicky: I am also looking for exact same but no luck till now.