How to install/use The jitsi Simultaneous Translation?

I see in some else jitsi discussions that exist a Jitsi based Simultaneous translation software but i don’t understand how to use it, if i can use the online jitsi service without host nothing on my computer and if i must host it in my computer what i should do for activate this service.

Thanks for the help.

What software is that? Is it a third-party addon?

What i found is this one discussion about some “Jigasi” and i found just now this one tool but i never used it

Right, JIgasi can do that, I thought you meant some other 3rd party software. You can read more about Jigasi here: GitHub - jitsi/jigasi: Jigasi: a server-side application acting as a gateway to Jitsi Meet conferences. Currently allows regular SIP clients to join meetings and provides transcription capabilities.

1 Like

Ok i have installed the jigasi to the 3th command so i runned


Now i don’t know what to do with XMPP, i never used it… i should install it as client or as a server?
I must set some specific thing?
I want to run the service in localhost just for a user so i don’t want that the meet is reachable from other users… what do you suggest me?

Do you have a working deployment of jitsi-meet?

No i haven’t, i need one or can i set it in localhost?

Jigasi is a component you add to an existing jitsi-meet deployment.

You can take a look at this architecture overview

1 Like

@damencho @saghul

Ok thanks for the suggestion, I don’t know if it is the case to close this discussion to open an another one, however i write here the next one question…

I’m following the instructions for install jitsi, i followed this one guide creating the Duck DNS anicedomainfortheoccasion[DOT]duckdns[DOT]org with the IPv4, after run the command sudo apt install jitsi-meet I have the following (i think good) situations but it doesn’t work yet.

$ sudo systemctl status jitsi-videobridge2                                                                                                 ──(Thu,May11)─┘
● jitsi-videobridge2.service - Jitsi Videobridge
     Loaded: loaded (/lib/systemd/system/jitsi-videobridge2.service; enabled; preset: enabled)
     Active: active (running) since Thu 2023-05-11 14:19:04 CEST; 6min ago
    Process: 38682 ExecStartPost=/bin/bash -c echo $MAINPID > /var/run/jitsi-videobridge/ (code=exited, status=0/SUCCESS)
   Main PID: 38681 (java)
      Tasks: 51 (limit: 65000)
$ sudo cat /proc/\`sudo cat /var/run/jitsi-videobridge/\`/limits
Limit                     Soft Limit           Hard Limit           Units     
Max cpu time              unlimited            unlimited            seconds   
Max file size             unlimited            unlimited            bytes     
Max data size             unlimited            unlimited            bytes     
Max stack size            8388608              unlimited            bytes     
Max core file size        0                    unlimited            bytes     
Max resident set          unlimited            unlimited            bytes     
Max processes             65000                65000                processes 
Max open files            65000                65000                files     
Max locked memory         8388608              8388608              bytes     
Max address space         unlimited            unlimited            bytes     
Max file locks            unlimited            unlimited            locks     
Max pending signals       30674                30674                signals   
Max msgqueue size         819200               819200               bytes     
Max nice priority         0                    0                    
Max realtime priority     0                    0                    
Max realtime timeout      unlimited            unlimited            us 

The following logs are too big


BUT trying to go to the anicedomainfortheoccasion[DOT]duckdns[DOT]org or to the IPv4 i have the error message Unable to connect, what can be wrong?

I have set IPv4 when i sent the install jitsi-meet command using my personal email, Let’s encrypt option and not using the phone option.

Did you open the necessary ports on your router?

You’re using a dynamic DNS; this is a problem.

@Freddie I’m using DuckDns because I read it in the guid, as follow

If your computer/server or router has a dynamic IP address (the IP address changes constantly), you can use a dynamic dns-service instead. Example DuckDNS.

What I should use? Consider that my connection is a phone hotspot and my computer is using Linux 23.04

Thanks at all for the help.

When I tried I used the university connection where of course they have an active firewall, however I should use it with my phone hotspot, what do you suggest about it? Can be a good idea or can I have some problems?

Actually, that’s my bad. Somehow, I saw that as a dynamic IP (the other way 'round). Indeed a service that automatically maps IP to your hostname in realtime is needed when you’re using a dynamic IP.

Try clearing all logs, then restart all services and do a test meeting again. Then gather and share the new logs to help figure out what could be going on.

On the firewall you need to forward port 443 to your machine where you host jitsi-meet and port UDP 10000.

I’m connected with an Android Phone hotspot with the following situation…

$ sudo ufw status verbose
Logging: on (low)
Default: deny (incoming), allow (outgoing), disabled (routed)
New profiles: skip

To                         Action      From
--                         ------      ----
80/tcp                     ALLOW IN    Anywhere                  
443/tcp                    ALLOW IN    Anywhere                  
10000/udp                  ALLOW IN    Anywhere                  
22/tcp                     ALLOW IN    Anywhere                  
3478/udp                   ALLOW IN    Anywhere                  
5349/tcp                   ALLOW IN    Anywhere                  
80/tcp (v6)                ALLOW IN    Anywhere (v6)             
443/tcp (v6)               ALLOW IN    Anywhere (v6)             
10000/udp (v6)             ALLOW IN    Anywhere (v6)             
22/tcp (v6)                ALLOW IN    Anywhere (v6)             
3478/udp (v6)              ALLOW IN    Anywhere (v6)             
5349/tcp (v6)              ALLOW IN    Anywhere (v6) 
$ ping
PING (xx.yy.zzz.kkk) 56(84) bytes of data.
64 bytes from (xx.yy.zzz.kkk): icmp_seq=1 ttl=58 time=406 ms
64 bytes from (xx.yy.zzz.kkk): icmp_seq=2 ttl=58 time=338 ms
64 bytes from (xx.yy.zzz.kkk): icmp_seq=3 ttl=58 time=247 ms
64 bytes from (xx.yy.zzz.kkk): icmp_seq=4 ttl=58 time=270 ms
64 bytes from (xx.yy.zzz.kkk): icmp_seq=5 ttl=58 time=403 ms
--- ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4001ms
rtt min/avg/max/mdev = 247.279/332.954/406.432/65.819 ms
$ ping
PING (xx.yy.zzz.kkk) 56(84) bytes of data.
--- ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4101ms
$ nmap -p 443,10000
Starting Nmap 7.93 ( ) at 2023-05-11 17:08 CEST
Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn
Nmap done: 1 IP address (0 hosts up) scanned in 4.97 seconds