[How to] How do I use the new Lobby Feature?

modules_enabled = {"muc_lobby_rooms} goes under the VirtualHost “guest.example.com
?

How did you do it mate? Can you post the change you made ?

Hi, no. You need to enable lobby_rooms in main VirtualHost (example.com) section and delete it from guest section (guest.example.com).

This is in video.example.com.cfg.lua under prosody/conf.d/ right?

I’ve renamed my config, but yes, it is prosody config file.

Here is my config file VirtualHost "example.com" --enabled = false -- Remove this line to ena - Pastebin.com and for the life of me I dont know what to change here… We have an important meeting tomorrow, I gotta figure this out ASAP. Really appreciate the help. Thanks

Is your installation working already? Can you make meetings?

yes but lobby option doesnt show up anymore under security options

do what I’ve said to you, adopt your config.

There is no lobby_rooms… There is muc_lobby_rooms under modules_enabled but thats it.

yes that’s it, I’m lazy to write it complete :slight_smile: Simply remove it form guest section and move it to main example.com virtualhost section.

@Seferi here’s what you currently have in your cfg.lua:

VirtualHost "guest.your.domain.com"
    authentication = "anonymous"
    c2s_require_encryption = false
    modules_enabled = {
            "muc_lobby_rooms";
        }
       
        lobby_muc = "lobby.your.domain.com"
        main_muc = "conference.your.domain.com" 
-- muc_lobby_whitelist = { "recorder.your.domain.com" } -- Here we can whitelist jibri to enter lobby enabled rooms

That has to change with the new version. You’re moving that muc_lobby_rooms e.t.c. to your main virtual host, so this block of your cfg.lua should now look like this:

VirtualHost "your.domain.com"
    -- enabled = false -- Remove this line to enable this host
    authentication = "internal_plain"
    -- Properties below are modified by jitsi-meet-tokens package config
    -- and authentication above is switched to "token"
    --app_id="example_app_id"
    --app_secret="example_app_secret"
    -- Assign this host a certificate for TLS, otherwise it would use the one
    -- set in the global section (if any).
    -- Note that old-style SSL on port 5223 only supports one certificate, and will always
    -- use the global one.
    ssl = {
        key = "/etc/prosody/certs/your.domain.com.key";
        certificate = "/etc/prosody/certs/your.domain.com.crt";
    }
    speakerstats_component = "speakerstats.your.domain.com"
    conference_duration_component = "conferenceduration.your.domain.com"
    -- we need bosh
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
        "speakerstats";
        "turncredentials";
        "conference_duration";
        "muc_lobby_rooms";
    }
    c2s_require_encryption = false
    lobby_muc = "lobby.your.domain.com"
    main_muc = "conference.your.domain.com"
    -- muc_lobby_whitelist = { "recorder.your.domain.com" } -- Here we can whitelist jibri to enter lobby enabled rooms
2 Likes

That did it mate, thanks a bunch!!!

Bonjour, did you find a solution? I’m facing the same issue.

No, not yet. I opened a GitHub issue where some other people also complained about this.

That has to change with the new version. You’re moving that muc_lobby_rooms e.t.c. to your main virtual host, so this block of your cfg.lua should now look like this:

Thanks @Freddie

@damencho I checked the release notes on that release and this change is not mentioned… where can I find such (in my eyes) major config changes breaking the current config to avoid spending a lot of time searching (and this thread shows, I was not the only one).

It is there as " * Always query the main domain for features. Fixes jitsi/jitsi-meet#8173 (#1428)"

1 Like

Its not a breaking change, but a fix, it was not working correctly and moving that config was a workaround. You can check the prosody config template where it was always enabled on the right place where it was designed to be.

1 Like