[How to] How do I update Prosody?

Have you already installed Jitisi-Meet using the steps outlined in the Quick Start / Handbook and now you want to enable other features like “speakerstats” or “conferenceduration”? Maybe you are not getting muc-occupant-joined and muc-occupant-left events in your modules?

Some of these features in Jitsi Meet require Prosody 0.11.2 +

:information_source: Note: If you update prosody before installing jitsi-meet, then things will just work. Follow only steps 1 - 4 below, then continue with your to install Jitsi

What version of Prosody do you have? Run apt list -a prosody

To update Prosody after Jitsi Meet has been installed, follow these steps:

  1. Add the repo to your sources.list
    echo deb http://packages.prosody.im/debian $(lsb_release -sc) main | sudo tee -a /etc/apt/sources.list

  2. Get the packages key
    wget https://prosody.im/files/prosody-debian-packages.key -O- | sudo apt-key add -

  3. Update repositories
    sudo apt-get update

  4. Install the latest
    sudo apt-get install prosody

  5. If there was a conflict with your “cfg” while updating, you would have seen it during the install. You may have a backup filed named prosody.cfg.lua.dpkg-old. If you had something special in there, you could move it back in place with:
    sudo mv /etc/prosody/prosody.cfg.lua /etc/prosody/prosody.cfg.lua.new && sudo mv /etc/prosody/prosody.cfg.lua.dpkg-old /etc/prosody/prosody.cfg.lua

  6. Make sure the last line in your prosody.cfg.lua is Include "conf.d/*.cfg.lua"
    sudo vi /etc/prosody/prosody.cfg.lua
    (I also commented out VirtualHost "localhost" to --VirtualHost "localhost")

  7. Edit your prosody config and change storage from “none” to “memory”:
    vi /etc/prosody/conf.avail/meet.domain.com.cfg.lua
    Replace: storage = "none" with storage = "memory"
    Failure to do this will cause errors like OperationFailedException: Failed to join the room and Exception while trying to start the conference

  8. Restart service prosody restart && service jicofo restart


Other messages that this post helps with:

  • conference duration will not work with Prosody version 0.10 or less.
  • speaker stats will not work with Prosody version 0.10 or less.
7 Likes
[How to] How do I use the new Lobby Feature?
[How to] How to upgrade Jitsi Meet & Monitor the logs
Is there a documentation for the lobby feature just arrived
Keep a registry
Secure Domain setup problem - Client disconnected: ssl handshake failed
[How To] How to enable websockets (xmpp-websocket) and smacks for Prosody
Install allowners prosody module
Updating Jitsi, Prosody, etc
Killing zombies in meetings
Should I still use nightly for the lobby feature?
[SOLVED]I can't activate the lobby function
TeamCloud problems
Secure Domain setup not working for me
Close conference
[Help Needed] I am launching jitsi server via coding using existing jitsi server image, facing issues with auth.domainname.key and auth.domainname.crt for prosody and jicofo
Strophe 504 Errors Occur when setting storage = "sql"
[How to] How do I use the new Lobby Feature?
[How to] How to upgrade Prosody for Jitsi
[How to] How do I use the new Lobby Feature?
[Solved] Where to add the "muc_max_occupants" to limit participants in a meeting?
JWT Authentication
Fails to turn on debug log level in Prosody 0.9.10
Upgrade Prosody - Video and audio not working
Is there a documentation for the lobby feature just arrived
Is there a documentation for the lobby feature just arrived
After lock the room, the transcriber cannot join any more
Get the list of rooms
[SOLVED] How to show Conference Duration in jitsi video call
How to use JWT token in jitsi external API
Problem with links created for meetings (they never expire)
Can't find Lobby Feature
Prosody "Error: Storage disabled"/"Error: No data storage active"

Thank you for writing these up :slight_smile: Just followed these instructions and now I’m getting a GET_SESSION_ID_ERROR when I try to log in to a room. Any ideas?

It was because I’d missed one of the storage = "none" lines in the configuration. Now that they’re all set to storage = "memory" it’s all working as it should. Thanks again for writing this up; it’s been a great help :slight_smile:

1 Like

during the update everything is fine till step 5 but i didn’t see the line in step 6 what to do??

@Dibyajyoti_Prusty,

Just add Include "conf.d/*.cfg.lua" at the bottom, as the last line of /etc/prosody/prosody.cfg.lua. Also comment out VirtualHost "localhost" as stated in step 6.

1 Like

@corby I have followed your mentioned steps but now when users are joining lets say room “abc” they are not able join same room

Only single user is visible

Read back through and make sure you did everything as described. Some people miss parts of setup 6 or step 7. If you still have issues, maybe you can attach your 2 Prosody cfg files and the log file for the community to review.

Also, if you had other issues before attempting to update Prosody, that’s will remain. If all else fails, start fresh but update Prosody before installing Jitsi Meet.

Hope this helps!

hi, thank you for the information about updating prosody, my prosody finally could update on 0.11 as well. However, i was facing some issue here. After I updated it and doing your instructions, I tried to run my jitsi’s server along with secure domain configuration. But after login, the “waiting for host” popup panel won’t close (see image), but there were no error or warning on its js console. After that, I realized something has changed on some line on global prosody config (prosody.cfg.lua) outside of what @corby has told to change, such as its authentication (from internal_plain to internal_hashed).

I’ve already done some scenario, either changed it back to internal_plain, or changed /etc/prosody/conf.avail/mydomain.com.cfg.lua that has authentication internal_plain to be internal_hashed, but got nothing. My prosody 0.11 global config actually look like this + Include "conf.d/*.cfg.lua" and commented VirtualHost "localhost".

Now, I revert back my prosody into 0.9.10, but i’m looking forward to applying prosody to be 0.11, since I want my apps using token authentication, do you have any ideas what i should do? Thank you.

Hi,
Thank you for this topic
after update prosody, my authentication ldap no longer works.
After several days of research, i need help please.

Error in the prosody logs:

Nov 14 18:26:51 localhost:auth_ldap2    error   Failed to load the LuaLDAP library for accessing LDAP: /usr/lib/prosody/util/startup.lua:201: module 'lualdap' not found:
            no field package.preload['lualdap']
            no file '/usr/lib/prosody/lualdap.lua'
            no file '/usr/local/share/lua/5.2/lualdap.lua'
            no file '/usr/local/share/lua/5.2/lualdap/init.lua'
            no file '/usr/local/lib/lua/5.2/lualdap.lua'
            no file '/usr/local/lib/lua/5.2/lualdap/init.lua'
            no file '/usr/share/lua/5.2/lualdap.lua'
            no file '/usr/share/lua/5.2/lualdap/init.lua'
            no file '/usr/lib/prosody/lualdap.so'
            no file '/usr/local/lib/lua/5.2/lualdap.so'
            no file '/usr/lib/x86_64-linux-gnu/lua/5.2/lualdap.so'
            no file '/usr/lib/lua/5.2/lualdap.so'
            no file '/usr/local/lib/lua/5.2/loadall.so'
    Nov 14 18:26:51 localhost:auth_ldap2    error   More information on install LuaLDAP can be found at http://www.keplerproject.org/lualdap

Ubuntu 18.04.3 LTS
jitsi-meet:all/stable 2.0.5142-1
prosody:amd64/bionic 0.11.7-1~bionic4

Thank you,

Looks like this was resolved here for others that may find their way to this topic/reply.

Port 5269 and 5280 related to XMPP is already running with ejabbered, but when I tried to install the jitsi, then I came to know that prosody is using the same ports.
Can we set it to a different port?
Any help?