How to enable TURN server with docker-jitsi-meet?

Hi all,

since the TCP harvester is disabled, I am trying to get our (docker-compose) jitsi instance to work with a separate turn server.
Unfortunately the documentation for the docker setup in this regards is very poor. The only configuration in this regards is done via the following parameters in the .env file, which I set as followed:

TURN_CREDENTIALS=user:password
TURN_HOST=jitsi-turn.XXXX.cloudapp.azure.com
TURN_PORT=3478

However, this seems not to be sufficient. Are there any other parameters that need to be set in order to make this work?

Is it necessary to also set TURNS_HOST and TURNS_PORT?

Or is it simply currently not working in a docker-compose setup?

Thank you for your help!

@saghul and @damencho do you have any ideas?

We were finally able to solve this.

To answer my own question: setting the TURN_* env variables is sufficient. However, you need to do this the right way.

One thing we die wrong was the TURN_CREDENTIALS. This didn’t work with user:password but with providing a secret.

Eventually it worked with the following settings:

TURN_CREDENTIALS=turnSecret
TURN_HOST=turn.XXX.azure.com
TURN_PORT=443
TURNS_HOST=turn.XXX.azure.com
TURNS_PORT=443

1 Like