How to enable/show conference timer in the room?

Hi,

I see that there is code to fetch the conferenceTimestamp but its returning undefined value always. Maybe some action dispatch is missing. Has anyone had any luck in enabling the timer for the conference room ?

Please note that the timer should retain its existing value for all the users that join it either on same machine (different browser tabs) or different machines.

Let me know, if anyone has done this.

TIA

There is a backend module enabled in prosody, which is supported only on prosody 0.11 https://github.com/jitsi/jitsi-meet/blob/master/resources/prosody-plugins/mod_conference_duration_component.lua

1 Like

Thanks for the quick response. I am running jitsi-meet. I want to understand how do the other 3 modules like prosody, jifoco and the other one (don’t remember the name) interact with the jisti meet frontend ?

If I integrate prosody 0.11 with jitsi meet, will the timer start working without any changes ?

Also, the below code returns undefined at the moment

/**

  • Returns the UTC timestamp when the first participant joined the conference.

  • @param {Function | Object} stateful - Reference that can be resolved to Redux

  • state with the {@code toState} function.

  • @returns {number}

*/

export function getConferenceTimestamp(stateful: Function | Object): number {

const state = toState(stateful);

const { conferenceTimestamp } = state['features/base/conference'];

return conferenceTimestamp;

}

conferenceTimestamp is undefined. Is this conferenceTimestamp is the timestamp to be used and when displaying the timer we do a diff of the current time with this to show the timer ?

And this conferenceTimestamp retains its value for all the participants of the same conference ?

I would like to understand while running the app locally, how can I communicate between all 4 modules.

Right now I am running only this one:- https://github.com/jitsi/jitsi-meet/blob/master/doc/development.md

When you run locally it is just the frontend code that is beeing proxied. Prosody is on the server you use as a backend, you need to make changes there if you want to change the prosody modules.
If you are asking how is done the communication between the web code and the timer module, here is the PR that added that functionality so you can take a look:

And the jitsi-meet PR https://github.com/jitsi/jitsi-meet/pull/4958

will the timer start working without any changes ?

Based on the PR linked above, these are the changes to my config I had to get the timer working:

Text form: https://haste.rys.pw/raw/apacirekiq

Hi @Martin_Rys,

After pulling the latest code from jitsi-meet as well as lib-jitsi-meet and following instructions in the readme for manual installation, this application still doesn’t work.

Below is what we found:-

Manual jitsi installation using https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md is not working

I think documentation is not sufficient. Even nginx documentation in it, doesn’t seem to be sufficient.

Also restart of services, on boot, like jvb, prosody and jicofo is not working. It has to be restarted manually. Only nginx can be restarted on boot. (systemctl restart nginx)

To restart manually we have to use below commands.

prosodyctl restart
/bin/bash /root/jitsi-videobridge-linux-x86-1132/jvb.sh --host=localhost --domain=meet.hostbread.com --port=5347 --secret=Apr@2020 &
/bin/bash /root/jicofo/jicofo-1.1-SNAPSHOT/jicofo.sh --host=localhost --domain=meet.hostbread.com --secret=Apr@2020 --user_domain=auth.meet.hostbread.com --user_name=focus --user_password=Apr@2020 &

After running above manually many auth and ssl errors :

Below are the logs :

root@meet:/var/log# ls
alternatives.log btmp dpkg.log jvb.log messages prosody wtmp
apt daemon.log faillog kern.log nginx syslog
auth.log debug fontconfig.log lastlog ntpstats unattended-upgrades

root@meet:/var/log# tail prosody/prosody.log
Apr 26 17:15:30 c2s560691e2c4e0 info Client connected
Apr 26 17:15:30 c2s560691e2c4e0 info Client disconnected: ssl handshake failed
Apr 26 17:15:35 c2s56069219b7e0 info Client connected
Apr 26 17:15:35 c2s56069219b7e0 info Client disconnected: ssl handshake failed
Apr 26 17:15:40 c2s5606921f2200 info Client connected
Apr 26 17:15:40 c2s5606921f2200 info Client disconnected: ssl handshake failed
Apr 26 17:15:42 c2s560692240190 info Client connected
Apr 26 17:15:42 c2s560692240190 info Client disconnected: ssl handshake failed
Apr 26 17:15:45 c2s560691f4a750 info Client connected
Apr 26 17:15:45 c2s560691f4a750 info Client disconnected: ssl handshake failed
root@meet:/var/log# tail jvb.log
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentMana
ger.java:222)
at org.jitsi.meet.ComponentMain.lambda$getConnectCallable$0(ComponentMain.java:286)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(Sc
heduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Scheduled
ThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
root@meet:/var/log# tail nginx/error.log
2020/04/26 17:08:07 [error] 753#753: *21 no “ssl_certificate” is defined in server listening
on SSL port while SSL handshaking, client: 123.201.194.49, server: 0.0.0.0:443
2020/04/26 17:08:26 [error] 753#753: *22 no “ssl_certificate” is defined in server listening
on SSL port while SSL handshaking, client: 123.201.194.49, server: 0.0.0.0:443
2020/04/26 17:08:26 [error] 753#753: *23 no “ssl_certificate” is defined in server listening
on SSL port while SSL handshaking, client: 123.201.194.49, server: 0.0.0.0:443

Can you confirm if the stable packages mentioned in below quick install link is latest so that we dont have to do manual configuration

(echo ‘deb https://download.jitsi.org stable/’ >> /etc/apt/sources.list.d/jitsi-stable.listwget -qO - https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -

apt-get -y install jitsi-meet)

Can you confirm that manual install setup.md isn’t to be used when running this application on a server. It’s only to be used when running the app locally ?

Also please confirm are the packages mentioned in this quick install and setup guide the latest one’s ?

Manual install is out of date and uses JVB1 instead of JVB2, git jicofo will not work with JVB1 anymore.

Trying to figure out a JVB2 install myself, am planning to touch up the manual-install doc when I do so.

Can you provide detailed steps if I am doing a fresh install on my server, to get the timer working.
The timer still doesn’t show up on our website.

@damencho . Is there any way we can hide the conference timer by overriding some config variables via Iframe API?

Yep jitsi-meet/configWhitelist.js at 49583b611c240188c3478bbd1627391c2b57562f · jitsi/jitsi-meet · GitHub

Is there any way to disable date in jitsi meet?

Client disable is in my previous post. Server disable is just comment these:

Hello Damencho,

Much thanks for the prompt respone.

The whitelist parameter of ‘hideConferenceTimer’ hides the timer only or it will disable it as well ? Secondly, I have commented the parameters in prosody however, the conference still display the date and time. Please guide me.

Thankyou

I’m confused. Where is the date and time shown? The timer only shows the duration of the meeting AFAIK.

So, your question is completely different from what’s being addressed in this thread. What you’ve highlighted is the Recents List. You want to remove the date and time and only show conference name?

i want to disable date and time function and i suppose it wont be displayed then