How to enable mobile browser in jitsi-meet

I try this solutions but it still not working

That workaround is no longer needed. Just disable deeplinking in your config.js.

disableDeepLinking: true,

I try to modify /etc/jitsi/meet/mywebsite.com-config.js file.
uncomment that line and set the value to true.
Change from
// disableDeepLinking: false,
To
disableDeepLinking: true,

but it still not working although I did restart to the system

Can you share your full config.js?

config.js.txt (60.1 KB)

I checked your deployment; with disableDeepLinking set to true, it works fine on me end. Using a mobile browser, I was sent straight to the meeting in the browser.

it will open but the camera and voice can not access it.
participants who are open from the mobile browser can’t hear me and I can not hear them, if there are missed configurations that need to set up.

thank.

That’s a totally different issue and likely has nothing to do with them using mobile browsers. Try hosting a 3-party meeting using desktop browsers, share your results.

with two tabs share voice and video after a minute but on a 3-party meeting not share the camera and voice, and two other tabs show the voice in muted and video in off, although I did not turn off and allow it when joined the meeting.

So your bridge is not working. Check your firewall. Make sure all necessary ports are open and accessible. Check port 10000/udp especially; make sure it’s open and properly forwarded, if behind a NAT.

all allowed :

Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), disabled (routed)
New profiles: skip

To Action From


80/tcp ALLOW IN Anywhere
443/tcp ALLOW IN Anywhere
10000/udp ALLOW IN Anywhere
22/tcp ALLOW IN Anywhere
3478/udp ALLOW IN Anywhere
5349/tcp ALLOW IN Anywhere
80/tcp (v6) ALLOW IN Anywhere (v6)
443/tcp (v6) ALLOW IN Anywhere (v6)
10000/udp (v6) ALLOW IN Anywhere (v6)
22/tcp (v6) ALLOW IN Anywhere (v6)
3478/udp (v6) ALLOW IN Anywhere (v6)
5349/tcp (v6) ALLOW IN Anywhere (v6)

also: I try three participants from different pc it is not working, join the meeting but not each one sees herself only.

Where is your server hosted?

IBM Linux machine.
after checking service jitsi-videobridge2 status
it’s active.

Check port 10000/UDP accessibility:

1 Like

no change , how to make it accessable

also, this is the firewall-allowed port, there is another config needed to be set up
all allowed :

Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), disabled (routed)
New profiles: skip

To Action From
80/tcp ALLOW IN Anywhere
443/tcp ALLOW IN Anywhere
10000/udp ALLOW IN Anywhere
22/tcp ALLOW IN Anywhere
3478/udp ALLOW IN Anywhere
5349/tcp ALLOW IN Anywhere
80/tcp (v6) ALLOW IN Anywhere (v6)
443/tcp (v6) ALLOW IN Anywhere (v6)
10000/udp (v6) ALLOW IN Anywhere (v6) < ----------------
22/tcp (v6) ALLOW IN Anywhere (v6)
3478/udp (v6) ALLOW IN Anywhere (v6)
5349/tcp (v6) ALLOW IN Anywhere (v6)

Again, if your server is behind a NAT, you need to forward those ports. You can open the ports in your firewall but still have problems connecting.

which tool use 10000/udp port? so I can check it, the 10000/udp port is forward but I can not test it using the above steps, if videobridge service use this port the status for videobridge is active .

Jitsi Videobridge

That’s good so here the service is working fine right?
please check the image I see an error word in the CGroup line. if is okay or not ?

so, it uses and opens the port 10000/UDP if it goes forward right?

We know it is working (you already shared its status). Nobody said it doesn’t…

The issue seems related with the firewall rule which is completely a different topic.