How to enable JWT in docker based Jitsi

Hello Community,

We have Self hosted (Docker) Jitsi Server running. We Wanted to enable moderated Jitsi meet in it.
For the Same We have microservice running for moderated meeting on another server.
But meetings are not getting created and for that we need to enable JWT in our Docker-based Jitsi Server.
We have followed following Steps:
In .env File.

ENABLE_AUTH=1

# Enable guest access
ENABLE_GUESTS=1

# Select authentication type: internal, jwt or ldap
AUTH_TYPE=jwt

# JWT authentication

# Application identifier
JWT_APP_ID=JWT_ID

# Application secret known only to your token generator
JWT_APP_SECRET=JWT_SECRET

In config.js

moderatedRoomServiceUrl: 'https://moderated.subdomain.domain.com',

In jitsi-meet.cfg.lua file

VirtualHost "subdoamin.domain.com"

    authentication = "token"
    app_id = "JWT_ID"
    app_secret = "JWT_SECRET"
    allow_empty_token = false

Are we missing something?

1 Like