How to enable colibri/stats in docker installations

About jitsi-videobridge/blob/master/doc/statistics
what changes needs to be done to have /colibri/stats path work in a docker installation?

In jvb/sip-communicator.properties i have added colibri
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc,colibri
org.jitsi.videobridge.STATISTICS_INTERVAL=1000

but when i open my server adddress/colibri/stats i get nginx 404Not found error and i don’t know how to configure nginx to enable this if this is something missing in nginx configuration…

Thanks

also enabled
JVB_ENABLE_APIS=rest,colibri
in .env file

anything else?

curl -v http://127.0.0.1:8080/colibri/stats

  • Trying 127.0.0.1…
  • TCP_NODELAY set
  • connect to 127.0.0.1 port 8080 failed: Connection refused
  • Failed to connect to 127.0.0.1 port 8080: Connection refused
  • Closing connection 0
    curl: (7) Failed to connect to 127.0.0.1 port 8080: Connection refused

You need to enable the REST interface (the “colibri” options you added don’t do anything). See here:
https://github.com/jitsi/jitsi-videobridge/blob/master/doc/rest.md

Boris

Hi Boris,

I have changed colibri to xmpp in .env file
A comma separated list of APIs to enable when the JVB is started. The default is none.
See https://github.com/jitsi/jitsi-videobridge/blob/master/doc/rest.md for more information
JVB_ENABLE_APIS=rest,xmpp

i have read the explanations in rest.md file, but they are all about “jetty” and for normal installations. i am trying to enable it on docker installation which uses nginx; i think that makes the difference…

In anycase, i have tried to add following lines to /docker/current/.jitsi-meet-cfg/jvb/sip-communicator.properties files but did not help

org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
org.jitsi.videobridge.STATISTICS_INTERVAL=1000

org.jitsi.videobridge.rest.private.jetty.port=8080
org.jitsi.videobridge.rest.jetty.tls.port=443
org.jitsi.videobridge.TCP_HARVESTER_PORT=443
org.jitsi.videobridge.rest.jetty.port=443

I only want to access mydomain.com/colibri/stats , but still getting 404 Not Found

Still this issue unclear for me.
With the latest docker jitsi-meet version , which config files needs to be edited and which lines should be enabled and what kind of changes in nginx sould be made (if needed) ; i’d appreciate if anyone can give details about exact changes