How to downgrade prosody?

Hi, how can I downgrade prosody? I saw that installing jitsi-meet on ubuntu 18.04 I need prosody 0.11 but per tutorial always install 0.12. I couldn’t find a way to go back to version 0.11 in specific.

Should be same steps, but install the prosody-0.11 package instead of prosody.

But these are the only packages that come when I run “apt list prosody -a” command to find available versions in ubuntu 18.04:

prosody/unknown,now 0.12.0-1~bionic1 amd64 [installed,automatic]
prosody/bionic 0.10.0-1build1 amd64

For this installation I had followed the Self Hosting Guide tutorial

echo deb http://packages.prosody.im/debian $(lsb_release -sc) main | sudo tee -a /etc/apt/sources.list
wget https://prosody.im/files/prosody-debian-packages.key -O- | sudo apt-key add -type or paste code here

Is it in any of these commands that I send the old version?

sudo apt install prosody-0.11 ?

You’re listing versions on the prosody package, not prosody-0.11 which is where 0.11 version is now published.

So:

  1. Add the prosody repo using these commands – Self-Hosting Guide - Debian/Ubuntu server | Jitsi Meet
  2. sudo apt update
  3. sudo apt install prosody-0.11
1 Like

I have one more question. Everything went well, I managed to install it, but the version that comes from prosody is this:
prosody/focal 0.11.4-1 amd64
I noticed that it has been giving some errors to authenticate with JWT, so I searched and saw that I should use version 0.11.9, but it doesn’t come when I add the package repository. How could I get this specific version?

That means you’re still using prosody from package from ubuntu package repo, not the prosody one.

You’ll need to add Prosody package repository then install the prosody-0.11 package. That should give you the latest 0.11 version which is equivalent to 0.11.13.

It was giving error “JWT error: token required”. and I followed this step, for those who need it. I don’t know if it’s a usual mistake, but I believe it would be nice to mention it here. I had seen some answers on the forum reporting the same problem and they were talking about the prosody version, so I thought that would be my problem too.

Glad you found a solution to your problem.

It is quite likely that patch you referenced would not be needed if you were on a newer 0.11.x version of prosody and an updated Jitsi version.

In fact, the sed command you linked to which globally replaces module:hook with module:hook_global could break the existing plugin since it now already does hook_global (as of this commit pushed 2 years ago):

The reason why “upgrade prosody” is usually the suggestion is because the websocket-session event that the module relies on was only added to prosody in version 0.11.6:

Well I don’t know why so prosody comes with an old version, I followed the step by step that was sent here and I have the updated version of jitsi-meet.

jitsi-meet 2.0.7001-1
jitsi-meet-prosody 1.0.5913-1
jitsi-meet-tokens 1.0.5913-1
prosody-0.11 1nightly143-1~bionic

I don’t know if I understand the problem, but I’ll rephrase the question then. Sorry for the insistence, but as I’m having problems with video calls crashing in the old version, so I need to update the packages on my system.

OK, I followed the steps in the tutorial

And this is the version installed after following these steps:
prosody-0.11/unknown,now 1nightly143-1~focal amd64

If I understand what you said earlier, this is an old version. So changing my question, how am I going to install version 0.11.x? If when I go step by step taking the repository and installing with prosody-0.11 only this version comes, I’m a little confused :smiling_face_with_tear:

That’s the correct version. It’s from the prosody repo and would be equivalent to 0.11.13.

You previously had this, which is the old version, and probably came from the ubuntu package repo rather than the prosody one.

1 Like