How to disable Welcome Page and automatic room join

When I navigate to my Jitsi server with address: https://my.custom.jitsi.com

There comes a “Welcome Page” that list some rooms that are active. I want this feature turned off, so I turned it off using config: enableWelcomePage: true. This works.

Now when I navigate to the same address above, I’m redirected to random generated Jitsi room. I want this feature turned off. How can I do this?

It would be best if user didn’t join any room when there is no room name in the url.

You may create a custom html page

touch /usr/share/jitsi-meet/hello.html

and add the following as the first location block in your nginx site config

    location = / {       
        index hello.html;
        alias /usr/share/jitsi-meet/;
    }
1 Like

Thanks! This seems to do the trick. This way I can disable the Web UI features of Jitsi.