How to disable random room generation on Mobile App?

I’m able to do this for the web client through interface-config, but don’t know how to disable it for the mobile app. Any pointers on where to look?

There is no way unless you rebuild the app yourself. Check WelcomePage.native.js.

Ah, I see.
Thank you!

Sorry, one quick (additional) question: does the app pull any configuration settings from config.js or interface_config.js?

It pulls config.js but not interface_config.js.

Ok. Thank you.

I’m now trying to figure out which of these properties on WelcomePage.native.js actually disables the random room-name generation and how to set it. :thinking:

@saghul, hate to bother you, but can you please tell me which property exactly controls this generator and possibly how to set the value to “no” or zero? I’ve been poring over this code for a while and still can’t figure it out. I’ve tried fiddling with “WelcomePageLists” and different “hintbox” properties, but apart from a bunch of errors on the UI, nothing has worked. Please help?

No worries. Comment out this line: https://github.com/jitsi/jitsi-meet/blob/09124ad7e9e934974853f04a0ffc4aa5c14ac5de/react/features/welcome/components/WelcomePage.native.js#L77 that should do it.

1 Like

Phew! Like magic!
God bless you, @saghul! :pray:t5:

Can you tell us did the build work ok on ios? I can do a conference with video/audio on ios.

I haven’t done ios yet - will likely get to it this weekend. I don’t imagine it not working though. I’ll let you know.

1 Like

@Freddie Have you managed to disable them on the mobile App?

Yeah, it worked for me.

Wonderful !! @Freddie can you guide me on how to disable them, please ??

As advised by Saghul, right here:

@Freddie You mean I have to comment that line ? I need more explanation please?

Yes, just comment out that line and you’re good to go.

I did it but still, It can’t work @Freddie

@Freddie is it this line? cause for me it’s not working this._updateRoomname()