How to disable or customize some features?

I want to customize few things. I would like to know what files to edit.

  1. I want to disable video and screen sharing. Audio will remain enabled.

  2. I want to limit the number of concurrent users in a single meeting/conference.

You can control buttons in this file: https://github.com/jitsi/jitsi-meet/blob/master/interface_config.js

You need to enable muc_max_occupants module and set the setting muc_max_occupants

Component "conference.jitmeet.example.com" "muc"
    storage = "null"
    muc_max_occupants = 10
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        -- "token_verification";
	"muc_max_occupants";
    }
    admins = { "focusUser@auth.jitmeet.example.com" }
1 Like

I saw the file, but I do not understand which setting to change. I think you did not understand my question. I do not want to allow users to use video and screen sharing feature.

How to enable it? I have to put following under Component “conference.jitmeet.example.com” “muc” in the file /etc/prosody/conf.d/my-domain.cfg.lua

storage = "null"
    muc_max_occupants = 10
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        -- "token_verification";
	"muc_max_occupants";
    }

Correct?

You have buttons, camera and desktop, which you should disable. Also in config.js there is startVideoMuted, should be true. So users will start muted and will not be able to unmute as there is no button.

Yes.

Will try

One more thing about my second question. Just putting the code under Component … “muc” will enable the module? What about the file link you shared https://github.com/jitsi/jitsi-meet/blob/master/resources/prosody-plugins/mod_muc_max_occupants.lua

What to do with it?

That is the file with latests jitsi-meet you should already have it installed, this is from unstable.

I am using stable. To check whether I have the mod, I did cd /usr/lib/prosody/modules/ and sudo nano mod_muc_max_occupants.lua

There is no such file and it is creating a new one. What should i do?

With stable you need token package but that will reconfigure your deployment for other use-case.
You can try:

  1. Make sure this line is not commented in your prosody config https://github.com/jitsi/jitsi-meet/blob/master/doc/debian/jitsi-meet-prosody/prosody.cfg.lua-jvb.example#L1
  2. Create that folder
  3. Put in it the files from this folder
    https://github.com/jitsi/jitsi-meet/tree/master/resources/prosody-plugins
1 Like